Problème avec la formule somme.si (critère * par une autre plage)

Eric R

XLDnaute Nouveau
Bonjour,

J'ai un problème avec la formule somme.si. J'aimerais que lorsque la condition est respectée qu' elle multiplie 2 colonnes. J'ai joint un tableau à titre exemple.

Merci de votre aide !!

Eric R
 

Fichiers joints

chris

XLDnaute Barbatruc
Bonjour
Code:
=SOMME(SI($C$3:$C$8=C12;$D$3:$D$8*$E$3:$E$8;0))
à valider en matriciel
sinon
Code:
=SOMMEPROD(($C$3:$C$8=C12)*1;$D$3:$D$8;$E$3:$E$8)
 

CISCO

XLDnaute Barbatruc
Bonjour

Tu peux faire avec
Code:
SOMMEPROD(($C3:$C8=C12)*$D$3:$D$8*E$3:E$8)
@ plus

P.S : Salut Chris :)
 

CISCO

XLDnaute Barbatruc
Bonjour

Effectivement, s'il faut recopier vers le bas, il ne faut pas oublier les $...

@ plus
 

Discussions similaires


Haut Bas