Problème avec formule conditionnelle SI [Résolu]

Zeus

XLDnaute Nouveau
Re-bonjour.
J'ai une grille de tarifaire avec des tranches de montant et j'ai bien placé une formule pour trouver directement le tarif quand on place un quelconque montant dans la colonne appropriée. Le bas blesse pour le dernier montant.
Svp voir fichier annexe.
Le problème c'est d'intégrer cette condition : Si le montant est >5.000.000 alors frais = à 7750 + 1000 par millions supérieur à 5.000.000 + frais intermédiaire.
Donc frais de 7.000.000 = 7750 + 2000 = 9750.
7.055.000 = 7750 + 2000 + 1500 (frais correspondant à 55.000 dans la grille) = 11250

La formule qui fonctionne avec les autres montant est =SI(A2>0;INDEX(Table!$A$2:$C$100;EQUIV(A2;Table!$A$2:$A$100);3);" ")
Donc comment ajouter cette condition à la suite de celle-ci.

Merci d'avance.
 

Fichiers joints

Zeus

XLDnaute Nouveau
Salut JHA.
Intéressant ta formule. J'essaie de la faire entrer dans ma formule.

Merci déjà
 

chris

XLDnaute Barbatruc
Bonjour à tous

J'avais commencé, donc je poste avec la grille sous forme de tableau et une tranche de plus (on pourrait supprimer la colonne tranche max).
J'ai tout mis en variable (les 5 M et les 7 750)
mais la formule de JHA est 5 000 000 de fois plus efficace :).

Les effets de bord des règles de calcul des frais sont assez curieux....
 

Fichiers joints

Zeus

XLDnaute Nouveau
Merci Chris pour ta réponse.
Mais la formule de JHA ne fonctionne pas chez moi quand le montant = 5 000 000. Mais en bidouillant un peu, j'ai réussi à avoir exactement ce que je voulais grâce à sa formule.
Je viens de voir la tienne et ma foi, je la trouve aussi terrible.
Dans tous les cas grâce vous j'ai terminé mon tableau.

Merci à vous!
 

Fichiers joints

Zeus

XLDnaute Nouveau
Essayé et ça marche parfaitement. Comme quoi c'est pas qu'un seul chemin qui mène à Rome.

Merci.
 

Discussions similaires


Haut Bas