XL 2016 Plus possible d'obtenir la somme de plusieurs cellules au format heures

mistral123

XLDnaute Nouveau
Bonjour,
Je ne parviens plus à obtenir la somme de plusieurs cellules qui sont aux formats heurs et minutes.
Je joins le fichier qui me cause problème.
La somme des cellules des cases N ne se fait pas correctement, je ne sais pas pourquoi.
Merci de bien vouloir m'aider.
Qui peut me renseigner?
mistral123
 

Fichiers joints

Victor21

XLDnaute Barbatruc
Supporter XLD
Bonjour.

Vous essayez d'additionner du texte en N9.

Essayez plutôt en N4 :
VB:
=SI(OU(H4="Jours fériés";H4="Jours de congés";H4="certificat";H4="sans certificat";H4="pas date";H4="-";H4="Circonstance");0;3.5/24)
 

mistral123

XLDnaute Nouveau
Merci de la réponse, Patrick.
Mais, je désirais une explication sur les changements en fin de formule.
Car, je ne comprends pas la signification du changement.
a+
merci, mistral123
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Re,

"0:00" et "3:30" sont interprétés comme du texte.
Pour le contrôler, appliquez à H4:H8 le centrage horizontal "standard" : les valeurs seront centrées à gauche.
0 et 3.5/24 sont les équivalents, mais en numérique.
 
Dernière édition:

mistral123

XLDnaute Nouveau
Merci Victor21,
question1) Mais alors, pourquoi cela fonctionne dans les autres cellules ?
question2) Pourquoi, faut-il transformée les heures en format décimal ?
Merci vivement de votre aide.
Cale fonctionne bien sûr
mistral123
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Re,

Dans les autres cellules, l'opération force la conversion en nombre. Ex : SI(H4="récup. AV";I4-"3:30"...
Il existe une méthode pour ne pas les transformer : au lieu de somme (N4:N8), essayez N4+N5+N6+N7+N8

Edit : Bonjour, Jocelyn
:)
 
Dernière édition:

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour mistral123, l'ami victor21 :) ,

je vais commencer par répondre a la question 2 : c'est pour avoir une valeur numérique maintenant si tu ne veux pas passer en centieme tu peux écrire ta formule de N4:N8 de cette façon :

VB:
=SI(OU(H4="Jours fériés";
H4="Jours de congés";
H4="certificat";
H4="sans certificat";
H4="pas date";
 H4="-";
H4="Circonstance");"0:00"*1;"3:30"*1)
la multiplication par 1 va transformer "0:00" et "3:30" en valeur numérique

réponse a la question 1 tu effectues des opérations sur tes autres valeurs

info complémentaire le simple fait d'écrire -"3:48" rend numérique par contre toutes tes valeur "0:00" sont en texte dans la plage D4M8

Cordialement
 

mistral123

XLDnaute Nouveau
oK Jocelyn,
Ah, d'accord.
Vous me donnez des infos. qui sont explicites.
Malheureusement, ceux-là ne sont jamais données.
Merci vivement.
A+
mistral 123
 

Discussions similaires


Haut Bas