Non reconnaissance des dates

V

Vin100

Guest
Bonjour,

alors voila, j'ai un problème tout con !!!

Je vous explique :

j'ai crée un tableau avec comme intitulé de colonne, de F3 à Q3, une suite logique de date
exemple : F3 -> Octobre ; G3-> Novembre ; H3 -> Décembre ; I3 -> Janvier ; ...

En B1, j'ai inscrit la formule =AUJOURDHUI avec le format 'mois'

Puis dans mon tableau (par exemple en F4), j'ai inscrit la formule =SI(F3=B1;(SI(E4*B4>D4;(E4*C4)-D4;0);0)

Mais malheureusement ca ne fonctionne pas! il ne doit pas reconnaitre la similitude entre les dates!

Mais vois pa du tt comment résoudre ce pb, j'sui ouvert à toutes vos propositions ...

Merci par avance!
 
V

Vin100

Guest
j'ai le mois en cours avec la formule AUJOURDHUI
J'ai mis la cellule en format mois ('Juil-05')
 

Gael

XLDnaute Barbatruc
Bonjour Vincent, Bonjour Pascal,

Essaye aussi avec la fonction MOIS:

=SI(MOIS(B1)=MOIS(F3);...

@+

Gael
 

PascalXLD

XLDnaute Barbatruc
Modérateur
re

Oui Gaël tu as raison tout dépend comment vincent a écrit Octobre NOvembre etc

si c'est une date avec un format 'mmmm' amors il faut utiliser ta fonction

Si c'est du texte il faut utiliser ma fonction

Bon courage
 

Discussions similaires


Haut Bas