Résolu Autres ne pas afficher #N/A avec la fonction recherchv excel 2007

sofra45

XLDnaute Nouveau
bonjour,

voici mon problème avec la fonction recherchv.

dans excel 2007.

en cellule C19 j'ai un menu déroulant avec 4 mots, faible,modérée,grave et très grave;

en cellule D19 j'ai ma formule =RECHERCHEV(C19;$B$9:$C$12;2;FAUX) qui va chercher un nombre via le menu déroulant dans une plage (B19:C12).

quand j'ai rien dans la cellule C19 ça affiche #N/A en cellule C20 et j'aimerais que cela affiche une cellule vide dans la C20.

j'espère avoir été clair.

merci pour votre aide.
 
Ce fil a été résolu! Aller à la solution…

Fichiers joints

chris

XLDnaute Barbatruc
Bonjour

Imbrique ta fonction de recherche dans un test d'erreur

Je ne sais plus si sur 2007 SIERREUR existait
=SIERREUR(RECHERCHEV(.....);"")

sinon
=SI(ESTNA(RECHERCHEV(.....));"";RECHERCHEV(.....))
 
Ce message a été identifié comme étant une solution!

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas