XL 2013 MFC+joursem+jours fériés

Chapichapo

XLDnaute Nouveau
Bonjour à tous,

Je fais appel à vous car j'essaie de créer un calendrier avec MFC samedi et dimanche et jours fériés.

Seulement j'utilise la fonction joursem mais le tout est décalé d'un jour.

le 01/01 = il indique jeudi alors que c'est vendredi
la MFC ne fonctionne pas pour le jour férié : '=ou(b$5=1;B$5=7)
le samedi et le dimanche sont décalés en vendredi et samedi la formule '=B$4=RECHERCHEV(B$4;Recap!$A$4:$B$15;2;0) ne fonctionne pas

les lignes 1 à 4 seront masquées mais je les ai laissées pour plus de facilités
l'écriture est uniquement prévue dans la colonne à partir de A7
et ensuite se sont toutes les cellules blanches du tableau.

Quelqu'un pourrait-il m'apporter son aide pour que je puisse utiliser ce calendrier et ensuite créer les pages des mois suivants s'agissant d'un calendrier annuel ?

Comme cela sera un calendrier "partagé" se souhaiterait protéger les formules et les MFC.

Merci de votre collaboration
 

Pièces jointes

  • 2021excel.xlsm
    31.2 KB · Affichages: 5

Chapichapo

XLDnaute Nouveau
désolée je corrige

le 01/01 = il indique jeudi alors que c'est vendredi
la MFC ne fonctionne pas pour le jour férié : '=B$4=RECHERCHEV(B$4;Recap!$A$4:$B$15;2;0)
le samedi et le dimanche sont décalés en vendredi et samedi la formule
'=ou(b$5=1;B$5=7) ne fonctionne pas

merci
 

chris

XLDnaute Barbatruc
Bonjour

Un simple coup d’œil sur l'aide en ligne ou inutilisation de l'assistant fonction suffit à voir que cette fonction accepte un second argument indiquant quand commence la semaine car cela diffère selon les pays

Donc =JOURSEM(B5;2) serait plus approprié

Mais tu mélanges 2 concepts : le calcul du jour qui va renvoyer un nombre de 1 à 7 et non une date à formater
Donc ici =B5 avec le format jjj suffit

Pour info JOURSEM(B5) renvoie 7 soit en principe le 7/1/1900 mais en plus tu travailles en mode MAC et cela renvoie le 7/1/1904

La MFC doit être
VB:
=JOURSEM(B$5;2)>5 pour les WE
=NB.SI(Recap!B$4:B$14;B$5) pour les JF
Par ailleurs tu peux étirer la formule de C5 jusqu'à AC5 et en AD
Code:
=SI(MOIS(AD1)>MOIS(B5);"";AC5+1)
à étirer en AE et AF
 
Dernière édition:

Chapichapo

XLDnaute Nouveau
Chris,

un grand merci pour votre aide précieuse

Tout fonctionne.

Les jours de Pâques ne s'affichent pas en MFC et les jours vides de certains mois s'affichent en MFC "jours fériés"

Pourriez-vous m'aider ?

Merci
chapichapo
 

Pièces jointes

  • 2021excel.xlsm
    136.6 KB · Affichages: 6

chris

XLDnaute Barbatruc
RE à tous
Les jours de Pâques ne s'affichent pas en MFC et les jours vides de certains mois s'affichent en MFC "jours fériés"
Au lieu de 2 MFC par onglet tu en as des dizaines qui se contrarient les unes les autres d'où le problème

Et tu n'as pas appliqué les formules conseillées pour les lignes 5 et 6... j'ai souligné en rouge dans ma réponse tout ce que tu n'as semble-t'il par lu
 
Dernière édition:

Discussions similaires

Réponses
6
Affichages
627
Réponses
6
Affichages
224

Statistiques des forums

Discussions
288 581
Messages
1 893 168
Membres
169 777
dernier inscrit
Bazilecr
Haut Bas