Impression plage cellule selon valeur COMBOBOX

wrap food

XLDnaute Occasionnel
Bonjour à tous ,
Dans un fichier avec 37 onglets, je souhaiterais imprimer des plages de cellules définies à l'avance avec un bouton dans un Userform , selon le choix fait via un ComboBox qui se trouver dans le même Userform que celui du bouton d'impression.
Auriez-vous un début de solution
Merci d'avance
Cordialement
 

Fichiers joints

wrap food

XLDnaute Occasionnel
Bonjour

Désolé, je me suis trompé de fichier :(

En faite
Les plages sont dans les feuilles
=> Nom1; Nom2;Nom3 etc....
elles sont nommées:
demande1 ;demande2 ;demande3;........... jusqu'à demande20.
et les boutons correspondant sont dans l'Userform SAISIE ;
Impr_1;Impr_2;Impr_3;....................jusqu'à Impr_20.

je sais que c'est complexe, :eek: mais je ne m'en sort pas .:confused:.
Pourriez-vous m'aider?
Par avance Merci ..
Cdt
 

Fichiers joints

Staple1600

XLDnaute Barbatruc
Bonjour le fil, le forum

@wrap food
En attendant le VBA, ma contribution du samedi matin.
On peut aussi écrire ta formule comme ceci (en A34):
=SI(E34=0;0;TEXTE(A65;"""Du"" jjjjj jj mmm aaaa"))
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas