Formule pour calculer nombre de mots entre 2 dates par mois

Barbapapa

XLDnaute Occasionnel
Bonjour à tous ! , je n'arrive pas à trouver une formule pour calculer un nombre de mots entre deux dates pour chaque mois.
Ce que je souhaite, c'est d'avoir dans une cellule (par ex en F2) une formule qui permette de calculer le nombre de fois que le mot "présent" est inscrit entre le 20 d'un mois et le 19 du mois suivant (par ex : entre le 20 janvier et le 19 février) et ce pour toute l'année (entre le 20 janvier et le 19 février, entre le 20 février et le 19 mars, ...).
Merci d'avance et bonne journée.
Frédéric
 

Fichiers joints

chris

XLDnaute Barbatruc
Re : Formule pour calculer nombre de mots entre 2 dates par mois

Bonjour

Code:
=SOMMEPROD((D1:D130="Présent")*(B1:B130>=CNUM("20/01/2012"))*(B1:B130<=CNUM("20/02/2012")))
Il pourrait être plus sympa de prévoir une cellule date début et une cellule date fin...
 

Barbapapa

XLDnaute Occasionnel
Re : Formule pour calculer nombre de mots entre 2 dates par mois

Bonsoir Chris et Jbobo, et merci pour votre aide. Mes remerciements sont tardifs car j'ai pris le temps pour essayer vos solutions. En fait vos solutions à tous les deux m'ont été utiles.
J'ai fait un mix des 2 pour avoir ce que je cherchais.
J'ai mis en pièce jointe ce que j'ai fait avec vos idées.
Merci encore !
Frédéric
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas