Formule de calcul selon conditions et changement couleur caractère

rico77

XLDnaute Nouveau
Bonjour à tous, à toutes et au forum
Après avoir déjà fait appel à vos compètences, j'ai obtenu des solutions dans l'heure qui a suivie mon post et je butte à nouveau sur une difficultée...

Voilà mon problème, je voudrais que dans la case HS figure le cumul des heures supplèmentaires de la semaine (figurant en rouge dans le tableau) lorsque la position de travail est "MP".
Lorsque le samedi est travaillé il faut en plus rajouter 8h dans la case RC et 16h dans le cas d'un dimanche travaillé.
La position "DP" ne donne droit qu'à des RC au dela de 7H travaillées et ce quelque soit le jour...
Je voudrais également si possible que les caractères changent de couleur selon la position de travail sachant que j'ai 7 positions et qu'une mise en forme conditionnelle est impossible puisque 3 conditions maximum.
Merçi d'avance pour votre aide précieuse.
Cordialement
 

Fichiers joints

Tibo

XLDnaute Barbatruc
Re : Formule de calcul selon conditions et changement couleur caractère

Bonjour,

Un essai en U10 avec cette formule :

Code:
=SOMMEPROD((MOD(COLONNE($E11:$T11);3)=2)*($C10:$R10="MP")*$E11:$T11)
à recopier en U12, ...

Je te laisse tester

@+
 

rico77

XLDnaute Nouveau
Re : Formule de calcul selon conditions et changement couleur caractère

Bonsoir TIBO
merçi pour ta réponse, la formule fonctionne bien mais encore une chose...
Comment faire pour que les heures s'ajoutent automatiquement dans la case des RC sachant que quand je travaille un samedi c'est 8h à rajouter et si c'est un dimanche c'est 16h ? et tout ca en position "MP" !

Merçi encore
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas