Formule avec conditions sur dates [résolu]

darkneo

XLDnaute Nouveau
Bonjour,

je dispose d'une base de données sur des personnes et il faut que j'adresse des courriers de relance sous certaines conditions.

Pour cela, je souhaite avoir une colonne qui me permet de savoir à qui je dois adresser des courriers de relance :
Je veux que cette colonne contienne un texte spécifique (disons "Oui" pour le test) si [la date d'aujourd'hui - la date de la décision (colonne N)] est comprise entre 2 et 4 mois et si la décision (colonne M) était "à représenter".

Il me resterait à filtrer sur cette colonne au moment où je voudrais avoir la liste des personnes à qui je dois envoyer les courriers de relance.

J'ai donc cette formule qui ne fonctionne pas et je ne comprends pas bien pourquoi :
=SI(M3="A représenter" ET date(annee(N3);mois(N3)+2;jour(N3))<=AUJOURDHUI() ET date(annee(N3);mois(N3)+4;jour(N3))>=AUJOURDHUI();"Oui";"")


J'inclus un fichier exemple pour aider à comprendre ce que je veux au cas où ça ne serait pas clair.
 

Fichiers joints

Dernière édition:

piga25

XLDnaute Barbatruc
Re : Formule avec conditions sur dates

Bonjour,

Un essai comme ceci à mettre en E2 et à recopier vers le bas:
=SI(ET(C2="A représenter";DATE(ANNEE(D2);MOIS(D2)+2;JOUR(D2))<=AUJOURDHUI();DATE(ANNEE(D2);MOIS(D2)+4;JOUR(D2))>=AUJOURDHUI()); "Oui";"")
Autrement en gardant vos valeurs (le ET est mal placé) :
=SI(M3="A représenter" ET date(annee(N3);mois(N3)+2;jour(N3))<=AUJOURDHUI() ET date(annee(N3);mois(N3)+4;jour(N3))>=AUJOURDHUI(); "Oui";"")
mettre ceci :
=SI(ET(M3="A représenter";date(annee(N3);mois(N3)+2;jour(N3))<=AUJOURDHUI();date(annee(N3);mois(N3)+4;jour(N3))>=AUJOURDHUI()); "Oui";"")
Edit : Bonjour VDAVID
 
Dernière édition:

VDAVID

XLDnaute Impliqué
Re : Formule avec conditions sur dates

Bonjour Darkneo,

Tu peux essayer en E2:

=SI(ET(C2="A représenter";ET(AUJOURDHUI()-D2>61;AUJOURDHUI()-D2<123));"Oui";"")


Avec 61 et 123 le nombres de jour pour 2 et 4 mois

Bonne journée !

EDIT: Bonjour Piga25
 

darkneo

XLDnaute Nouveau
Re : Formule avec conditions sur dates

Merci piga25, ça marche.

L'erreur proviendrait donc du fait qu'Excel n'accepte pas trois conditions dans un ET "classique" ?
 

piga25

XLDnaute Barbatruc
Re : Formule avec conditions sur dates

Re

Si excel accepte les conditions dans un ET mais comme ceci ET(1ère condition; 2ème condition; etc..)
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas