XL 2010 Faire la concaténation de texte selon valeur d'une cellule

wafa-chaouni

XLDnaute Nouveau
Bonjour,

Je voudrais faire la concaténation du texte selon la date d'une cellule
J'ai plusieurs taches avec une date d'échéance, et je voudrais afficher l'ensemble des taches selon le jour de la tache.


Le fichier ci-joint est la référence, en gros au lieu de mettre "assignment due" dans la formule déja existante, il faut concaténer le texte des valeurs "les taches"
un exemple de sommeprod mais pour les textes

Je vous remercie pour ce forum.
 

Pièces jointes

  • To do list & Calendar.xlsx
    45.9 KB · Affichages: 7

Dranreb

XLDnaute Barbatruc
Bonjour.
Dans un module standard :
VB:
Option Explicit

Function TâchesÀDate(ByVal LaDate As Date, ByVal RngTab As Range) As String
   Dim TDon(), LD As Long, TRés() As String, LR As Long
   TDon = RngTab.Value
   ReDim TRés(1 To UBound(TDon, 1))
   For LD = 1 To UBound(TDon, 1)
      If TDon(LD, 2) = LaDate Then
         LR = LR + 1: TRés(LR) = TDon(LD, 1)
         End If: Next LD
   If LR = 0 Then TâchesÀDate = "Rien": Exit Function
   ReDim Preserve TRés(1 To LR)
   TâchesÀDate = Join(TRés, vbLf)
   End Function
En 'Week View'!B15, à propager sur 7 colonnes :
Code:
=SI(NBCAR(B14)=0;"";TâchesÀDate(DATE(WkYear;WkMonthNum;B14);Assignments))
Format, Alignement: Renvoyer à la ligne automatiquement.
 

Discussions similaires

Haut Bas