XL 2013 extraire le numéro de la ligne d'une cellule contenant une valeur

Norbert

XLDnaute Nouveau
Bonjour,
j'ai de nouveau besoin de votre aide...

Dans un tableau excel je souhaiterais afficher la valeur d'une cellule en recherchant une valeur dans le tableau. J'essaie d'utiliser les fonctions Equiv et Index, recherche...
Sans résultat.

Je joins un petit fichier pour la compréhension de ma demande.
Je souhaiterais afficher en B11, la valeur de la colonne A correspondant à la ligne ou je trouve la valeur de la cellule A11.
Idem pour B12 et A12......


Merci pour votre aide
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour Norbert,

Formule matricielle en B11, à valider par Ctrl+Maj+Entrée :
Code:
=SIERREUR(INDEX(A$1:A$7;PETITE.VALEUR(SI(B$1:D$7=A11;LIGNE(A$1:A$7));1));"")
A+
 

Fichiers joints

Norbert

XLDnaute Nouveau
Re bonsoir.

J'ai transcrit la formule matricielle dans mon tableau et je vois un problème.

En cellule C88 je devrais avoir R6, en C89 - R5 etc
et en C93 - R1

Merci à vous de jeter un oeil
 

Fichiers joints

job75

XLDnaute Barbatruc
La formule du post #2 suppose que la plage après INDEX commence à la ligne 1, à cause de la fonction LIGNE.

Vous avez 2 possibilités pour la formule en E88 ou F88 de votre dernier fichier :

- soit celle-ci =SIERREUR(INDEX(A$1:A$30;PETITE.VALEUR(SI(C$5:Z$30=C88;LIGNE(A$5:A$30));1));"")

- soit celle-là =SIERREUR(INDEX(A$5:A$30;PETITE.VALEUR(SI(C$5:Z$30=C88;LIGNE(A$5:A$30)-4);1));"")

Toujours matricielles bien sûr.
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas