XL 2013 Difficultés sur index / equiv et les formules matricielles

Gregoirehb

XLDnaute Nouveau
Bonjour à tous !

J'ai cherché un peu partout mais je ne trouve pas la solution... et pourtant je crois que je ne suis pas loin (mais je maîtrise très mal les formules matricielles)

En gros, dans un tableau contenant dans ses colonnes B et suivantes des mots et des variantes (orthographiques), je veux que, en tapant un mot, quelque que soit sa colonne, on puisse retrouver un code (qui serait inscrit en colonne A).
Je vous ai mis un exemple en attaché.

Spontanément je pense à un truc combinant Index et Equiv et les formules matricielles (comme on ne connaît pas la colonne du mot), mais je me trompe peut-être complètement et n'arrive pas à avancer.

Si vous avez des idées, je suis preneur ! ;)

Merci et désolé si ma question est évidente (il se peux que je passe à côté d'une solution évidente !)
 

Fichiers joints

Dernière édition:

phlaurent55

XLDnaute Barbatruc
Re : Difficultés sur index / equiv et les formules matricielles

Bonjour Grégoire,

avec cette formule en B14

=SOMMEPROD((B5:E10=A14)*(A5:A10))

à+
Philippe
 

Gregoirehb

XLDnaute Nouveau
Re : Difficultés sur index / equiv et les formules matricielles

Mon Dieu, c'est tellement une bonne idée, merci ! Je ne pense jamais à SommeProd quand j'ai du texte !
Merci encore !
 

R@chid

XLDnaute Barbatruc
Re : Difficultés sur index / equiv et les formules matricielles

Bonjour @ tous,
Salut Philippe,
si le code est alphanumérique il te faudrait une formule matricielle.
Code:
=SIERREUR(INDEX(A5:A10;PETITE.VALEUR(SI(B5:E10=A14;LIGNE(INDIRECT("1:"&LIGNES(A5:A10))));1));"")
@ valider par Ctrl+Shift+Enter


@ + +
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas