Copie conditionnelle du contenu d'une cellule

salland

XLDnaute Nouveau
Bonjour à tous,

Je souhaite copier le contenu de la cellule C10 en A1 si la cellule B10 contient quelque chose (une croix par exemple).
En d'autres termes:
- si B10 contient quelque chose alors copier le contenu de C10 en A1
- Si B32 contient quelque chose alors copier le contenu de C32 en A1

>>> la cellule destination est toujours A1
>>> il n'y aura qu'une cellule de la colonne B qui contiendra quelque chose

Merci à tous pour votre aide
 

Dull

XLDnaute Barbatruc
Re : Copie conditionnelle du contenu d'une cellule

Salut Salland, le Forum

Pas sur d'avoir compris mais essaye ça

Code:
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
Dim C As Range
For Each C In Range("B1:B100") [COLOR=Green]' Plage à adapter[/COLOR]
    If C <> "" Then [A1] = C.Offset(0, 1)
Next C
End Sub
Bonne Journée
 

JHA

XLDnaute Barbatruc
Re : Copie conditionnelle du contenu d'une cellule

Bonjour Salland, Bonjour Dull, le forum,

un essai pour ces 2 cellules

=SI(ET(NON(ESTVIDE(B10));NON(ESTVIDE(B32)));"Attention les 2 cellules sont remplies";SI(NON(ESTVIDE(B10));C10;SI(NON(ESTVIDE(B32));C32;"Veuillez cocher une cellule!")))

JHA
 

salland

XLDnaute Nouveau
Re : Copie conditionnelle du contenu d'une cellule

En fait je te joins mon fichier parce que j'arrive pas à adapter la macro!
Dans ce fichier je voudrai que la cellule H101 soit copiée en J14 parce qu'il y a une croix en B101.
Si la croix avait été en B102, ce serait la cellule H102 qui serait copiée en J14.
Est ce que tu peux m'aider encore?

Encore merci
 

Dull

XLDnaute Barbatruc
Re : Copie conditionnelle du contenu d'une cellule

Re Salland, le Fil

Ton Fichier en Retour

si C est en Colonne B

C.Offset(0,1) est égal a la cellule à Droite de C soit Colonne C

C.Offset(0,6)est égal à la Cellule 6 colonne à Droite soit Colonne H

EDITION: Remplace [A1] par [J14]

Bonne Journée
 

Fichiers joints

Dernière édition:

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas