XL 2016 Compter un mot une seule fois

pompaero

XLDnaute Occasionnel
Bonjour le forum,

J'aimerai dans mon fichier, onglet "Feuil1" en C5 avoir une formule qui compte une seule fois le mot Niveau (B5) par jour correspondant à la période de date de début (B1) et date de fin (B2)
Exemple :
si en avril se trouve dans l'onglet Action prevu, le :
04/04/2019 10:00 14:00 04:00 Niveau 5
04/04/2019 14:00 17:00 03:00 Niveau 7
04/04/2019 17:00 20:00 04:00 Niveau 5
alors compter une seule fois au lieu de 3 fois.
Merci
Cdt
pompaero
 

Fichiers joints

pompaero

XLDnaute Occasionnel
Bdjidji59430, le forum,

Merci de ta proposition du TCD, c'est très bien, j'y avais pensé mais pour le moment je préfère les formules afin de construire en allant la présentation qui en est qu'au début, car les statistiques que je dois effectués ont l'ère différents des uns des autres, j'imagine qu'avec les TCD cela semble difficile de tout regrouper (je verrai à la fin, ça fera un défis de plus..)
Merci
Cdt
pompaero
 

pompaero

XLDnaute Occasionnel
Bonjour JHA, le fil, le forum,

Ta proposition est pas mal, elle représente très bien le résultat attendu. Sans le tableau période se serai le top.
Pourquoi sans le tableau période !! parce que l'objectif est de pouvoir ressortir des stats sur 6 mois, 1 an, 2 ans, voir plus, et donc cela oblige à créer ou prolonger le tableau période sur 365 jours et plus.
Il faut le principe de ta formule du tableau période mais directement en cellule C5 (par exemple).
J'ai bien aimé également la formule du nb de jours entre 2 dates ;), que j'ai gardé du coup.
J'essai de mon côté de trouver une solution.
Merci
pompaero
 

job75

XLDnaute Barbatruc
Bonjour pompaero, djidji59430, JHA,

Voyez le fichier joint et cette formule en C5 :
VB:
=SOMMEPROD((B5=nomPrevu)*(PlageDatePrevu>=JourDebut)*(PlageDatePrevu<=JourFin)*(EQUIV(nomPrevu&PlageDatePrevu;nomPrevu&PlageDatePrevu;0)=LIGNE(PlageDatePrevu)-LIGNE(INDEX(PlageDatePrevu;1))+1))
Edit 1 : formule complétée en D5.

Edit 2 : soignez l'orthographe de "Accueil".

A+
 

Fichiers joints

Dernière édition:
  • J'aime
Reactions: JHA

pompaero

XLDnaute Occasionnel
Bonjour job75, le fil,

job75, cest juste magnifique, exactement ce l'ont souhaitaient, du coup j'ai super bien avancé dans mon projet et la présentation.
Perso, je n'aurai pas trouvé ce style de formule.
Pour le plaisir, je joins mon fichier pour voir ce que cela donne.
Merci
pompaero
 

Fichiers joints

Discussions similaires


Haut Bas