Compter le nombre d'éléments différents dans une plage.

Charly88

XLDnaute Occasionnel
Bonjour à tous, un problème très simple mais je sèche, voici une plage :

1
45
1
2
5
8
5

ou une autre A A B A C F A B T R

Par quelle formule compter le nombre d'éléments différents chacune des listes ? Ici on obtiendrait respectivement 5 et 6 éléments.
 

Tibo

XLDnaute Barbatruc
Re : Compter le nombre d'éléments différents dans une plage.

Bonjour,

Une première solution s'il n'y a pas de cellules vides :

Code:
=SOMMEPROD((1/NB.SI(A1:A10;A1:A10)))

S'il y a des cellules vides, une formule matricielle :

Code:
=SOMME(SI(A1:A10<>"";1/NB.SI(A1:A10;A1:A10)))

Formule matricielle à valider par CTRL + MAJ + ENTREE

Plages de cellules à adapter

@+
 

Charly88

XLDnaute Occasionnel
Re : Compter le nombre d'éléments différents dans une plage.

Merci à tous les deux pour ces formules, c'est petit mais costaud.

J'étais parti pour enchainer sur une question bateau d'élimination de doublons et je me suis perdu en route, jusqu'à une appli de ce cher Mdf que je n'arrive pas à installer pour le moment mais ça viendra.
 

Discussions similaires

Haut Bas