Compter le nombre de lignes dont une ou plusieurs colonnes est non vide

aurelren

XLDnaute Nouveau
Bonjour,

J'ai un souci pour trouver une formule.
J'ai un tableau de suivi clients avec :
- Lignes : un client par ligne
- Colonnes : une colonne par année
Le chiffre d'affaires est indiqué pour chaque client par année.

Je souhaite calculer plusieurs choses afin d'analyser la fidélité client :
- Nombre de Nouveaux clients, ayant du CA en année N
- Nombre de clients fidèles N et N-1, N et N-2, N et N-1 et N-2

Merci d'avance pour votre aide
 

Gorfael

XLDnaute Barbatruc
Re : Compter le nombre de lignes dont une ou plusieurs colonnes est non vide

Salut le forum
Pas assez d'infos pour donner une réponse élaborée.
formules>> informations>> estvide() testera si une cellule est vide ou non, avec une somme sur une plage, on connaît le nombre de cellules vides sur la plage :=SOMMEPROD(non(ESTVIDE(A1:A10))*1) donnera le nombre de cellules non vides sur la plage A1:A10

=SOMMEPROD(NON(ESTVIDE(A1:A10))*NON(ESTVIDE(B1:B10))) donnera le nombre de cellule non vide et A et non vide en B sur les lignes de 1 à 10

une réponse à un test logique donne :
0 si le test est faux
tout ce qui n'est pas 0 si le test est vrai. Et comme excel n'est pas intelligent, il retourne 1 pour les formules et -1 pour les codes macros.
A+
 

aurelren

XLDnaute Nouveau
Re : Compter le nombre de lignes dont une ou plusieurs colonnes est non vide

Bonjour,

Merci Gorfael, mais je ne pense pas que votre réponse soit ce dont j'ai besoin.

En fait, je ne veux pas compter le nombre de cellules, mais le nombre de lignes répondant à une requête précise.
Mon tableau se présente ainsi :
Colonne A : Clients
Colonne B : CA 2013
Colonne C : CA 2012
Colonne D : CA 2011

Je veux compter :
Les nouveaux clients : donc les lignes dont seule la colonne B est pleine
Les clients fidèles N-1 : lignes dont les colonnes B et C sont pleines
Les clients fidèles N-1 & N-2 : lignes dont les colonnes B, C et D sont pleines
Les clients perdus : lignes dont la colonne C est pleine, mais pas la colonne B

D'après ce que je comprends de votre proposition de formule, ça compterait les cases non vides en les cumulant.
C'est la seule chose que j'arrive à calculer...
 

CISCO

XLDnaute Barbatruc
Re : Compter le nombre de lignes dont une ou plusieurs colonnes est non vide

Bonjour

Pour être certain d'avoir une aide adaptée à ta demande, le mieux, c'est de mettre un ficher en exemple en pièce jointe (aller en mode avancé, en bas à droite. Gérer les fichiers en dessous de la fenêtre...).

@ plus
 
Dernière édition:

aurelren

XLDnaute Nouveau
Re : Compter le nombre de lignes dont une ou plusieurs colonnes est non vide

Bonjour,

Voici des détails supplémentaires sur ma question.
Ci-dessous, mon tableau (fictif)
Numéro Client CA 2013 CA 2012 CA 2011
1 Albert 210,93
2 Renard 580,65 650,1 214,52
3 Hautefeuille 1568,23
4 Jourda 50,89 112,87 88,22
5 Perraut 1232,5 1000,68
6 Meunier 567,23
7 Kleiber 247,68 255,33
8 Seigneur 1598,68 2632,33
9 Gunter 1123,32 233,54
10 Kitsch 5899,2 6422,33
11 Champs 1578,63 1699,32 1875,54
12 Peyroles 5362,22 4277,21
13 Astruc 569,54 479,22 138,22
14 Parot 578,66 530,25
15 Roman 210,69 456,3


Je recherche :
- Le nombre de nouveaux clients : CA en 2013 uniquement
- Le nombre de clients fidèles N-1 : CA en 2013 et 2012
- Le nombre de clients fidèles N-1 N-2 : CA en 2013, 2012, 2011
- Le nombre de clients perdus : CA en 2012 mais pas en 2013

Si je peux en plus avoir un listing des clients concernés pour chaque requête, alors là, c'est le top !

Merci !
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Re : Compter le nombre de lignes dont une ou plusieurs colonnes est non vide

Bonjour, aurelren.

Vous auriez probablement déjà une réponse si vous aviez suivi le judicieux conseil de l'ami CISCO qui par ailleurs ne fait que reprendre celui qui vous a été donné lorsque vous avez créé votre filPJ.jpg
 

Fichiers joints

R@chid

XLDnaute Barbatruc
Re : Compter le nombre de lignes dont une ou plusieurs colonnes est non vide

Bonjour et Bienvenue sur XLD,
Bonjour Patrick, Bonjour CISCO,
comme ils ont dit les amis un fichier exemple est toujours plus parlant, on ne demande pas le fichier réel :confused:
Voir PJ si ça te convient

@ + +

Edit : Ajout des clients perdus
 

Fichiers joints

Dernière édition:

aurelren

XLDnaute Nouveau
Re : Compter le nombre de lignes dont une ou plusieurs colonnes est non vide

Bonjour,

Merci beaucoup R@chid.
Le tableau en PJ et parfait, et les formules fonctionnent.
En revanche, je ne parviens pas à adapter les formules à mon tableau. Il fait 4936 lignes... Je ne sais pas si ça peut expliquer. Comme pour moi, tes formules sont assez "opaques", peut-être que je ne les adapte pas comme il faut.

Je retente.
Merci encore
 

R@chid

XLDnaute Barbatruc
Re : Compter le nombre de lignes dont une ou plusieurs colonnes est non vide

Bonjour @ tous,
La formule en H3 est une formule matricielle à valider par Ctrl+Maj+Entree et à tirer vers la droite. (cellules oranges)
La formule en K3 est à valider tout simplement par Entree. (cellule verte)

@ + +
 

Discussions similaires


Haut Bas