Compter des valeurs identiques [Résolu]

arn0

XLDnaute Nouveau
Bonjour !

Je souhaite inventorier les valeurs identiques d'une colonne. Exemple :
(ColonneA = CA)

CA
2
12
12
12
2
12
3
5

Résultat : 4
explication : il y du 12 (*4) ; du 2 (*2) ; du 3 (*1) et du 5 (*1)

puis, le nombre de valeurs idantiques :

CA CB
2 2
1 3
1 5
4 12

merci de m'avoir lu, si vous connaissez les formules...

Message édité par: arn0, à: 12/04/2005 15:46
 

arn0

XLDnaute Nouveau
Re:Compter des valeurs identiques

précision

Ca ressemble à la question de stephane sur : Comptage ds colonnes et changement de valeurs, sauf que moi, je ne connais pas à priori les valeures contenus dans ma colonne...

merci
 

Monique

XLDnaute Barbatruc
Re:Compter des valeurs identiques

Bonjour,

Une formule (matricielle) qui donne la liste des valeurs différentes de ta colonne A
[file name=ValeursDifferentesArno.zip size=2975]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/ValeursDifferentesArno.zip[/file]
 

Fichiers joints

arn0

XLDnaute Nouveau
Re:Compter des valeurs identiques

Merci Monique !

J'ais essayé ta formule matricielle, c'est exactement ce que je souhaite faire... merci beaucoup !!

Ceci-dit, j'ais un soucis... cela fonctionne pour la première valeure, ensuite, lorsque je copis les cellules, le résultat des suivantes est toujours identique. La seule différence qu'il y a avec ta matrice, c'est que moi, je souhaite mettre le résultat sur une autre feuille excel. Je fais donc référence à une autre feuille pour ma plage de donnée. Est-ce que cela peut en être la cause ?

Merci encore.
 

Monique

XLDnaute Barbatruc
Re:Compter des valeurs identiques

Re,

Si tu mets ta formule dans une autre feuille, tu as intérêt à nommer la plage A2:A20 et la plage A1:A20
(Insertion - Nom - Définir)

Une erreur facile à faire avec cette formule :
la plage est A2:A20,
mais la fonction Index est INDEX(A1:A20)
(c'est pour éviter de compter le nb de lignes au-dessus de A2:A20
et aussi pour avoir la possibilité d'insérer des lignes sans avoir à modifier la formule)

Si tu nommes Zone la plage A2:A20 et ColZone la plage A1:A20,
et si tu démarres en G2, ça donne :
=SI(SOMME(SI(Zone<>'';1/NB.SI(Zone;Zone)))<LIGNES(G$2:G2);'';INDEX(ColZone;PETITE.VALEUR(SI(NB.SI(G$1:G1;Zone)=0;SI(Zone<>'';LIGNE(Zone)));1)))
 

arn0

XLDnaute Nouveau
Re:Compter des valeurs identiques

Ca ne venait pas du changement de feuille, mais bien de 'l'erreur facile' !!

Merci encore !!
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas