Comment changer 20150423100502 en 23/04/2015 10:05:02

lmylvc

XLDnaute Occasionnel
HELLO LES AMIS
Je n'arrive pas à modifier une série de chiffres éditée au format standart en format indiqué dans l'intitulé.
Ci joint un fichier avec une formule qui m'affiche la date mais pas l'heure.

=SI(ESTERREUR(DATE(STXT(D2;1;4);STXT(D2;6;2);STXT(D2;8;2)));"";DATE(STXT(D2;1;4);STXT(D2;6;2);STXT(D2;8;2)))

Si quelqu'un pouvait m'aider cela serai super cool

Merci

Vincent:confused:
 

Fichiers joints

Dranreb

XLDnaute Barbatruc
Re : Comment changer 20150423100502 en 23/04/2015 10:05:02

Bonjour.
Code:
=DATE(GAUCHE(D2;4);STXT(D2;5;2);STXT(D2;7;2))+TEMPS(STXT(D2;9;2);STXT(D2;11;2);STXT(D2;13;2))
Format de nombre jj/mm/aaaa hh:mm:ss

Bonjour Victor21. Là il faut tout de même reconnaitre que la philosophie de Modeste Geedee de toujours passer par des String en comptant sur Excel pour les interpréter en nombre selon les séparateurs qu'ils contiennent peut quand même apporter une simplification appréciable.
 
Dernière édition:

Victor21

XLDnaute Barbatruc
Supporter XLD
Re : Comment changer 20150423100502 en 23/04/2015 10:05:02

Bonjour.

Essayez :
=DATE(STXT(D2;1;4);STXT(D2;5;2);STXT(D2;7;2))+TEMPS(STXT(D2;9;2);STXT(D2;11;2);STXT(D2;13;2))
au format "jj/mm/aaaa hh:mm:ss"

Edit : Bonjour, Dranreb. Bing :)
 
Dernière édition:

lmylvc

XLDnaute Occasionnel
Re : Comment changer 20150423100502 en 23/04/2015 10:05:02

Hello

Merci à vous tous
cela fonctionne bien
 

Discussions similaires


Haut Bas