Résolu XL 2016 Calculer le nombre de jours ouvrés par mois entre 2 dates

adie35

XLDnaute Nouveau
Bonjour,

je tourne en rond avec ma formule.
Je cherche à connaitre le nombre de jour ouvrés par mois entre deux dates.
ça va quand ça glisse que sur deux mois mais quand il y a trois mois concernés ça se complique.
Le but étant après de faire un tcd pour connaitre les totaux par mois.

Faut-il que je fasse par exemple 12 colonnes de calcul représentant les 12 mois etc...

Ci-joint un exemple.

En vous remerciant par avance pour votre aide
 
Ce fil a été résolu! Aller à la solution…

Fichiers joints

chris

XLDnaute Barbatruc
Bonjour

Quand on multiposte sur plusieurs forums, il est bien de s'en souvenir et d'aller y chercher les réponses données

De même tu ne sembles pas très sûre de ta version tantôt 2016, tantôt 2019...
 

GALOUGALOU

XLDnaute Impliqué
Bonjour adie35; bonjour le fil, bonjour le forum
précision : les jours ouvrés , suppose samedi dimanche et fériés, donc formule NB.JOURS.OUVRES. pour une autre déclinaison préférer la formule nb jours ouvres intl qui permet de choisir les jours de fermeture

dans le classeur la feuille liste,
-se trouve les jours fériés par formule (supprimer ceux travaillé, comme lundi de pentecote, rajouter les jours fériés propre à votre région (ex st nicolas))
-se trouve en cellule e2 le choix des jours de fermeture

dans la feuille1 l'intervalle de date est découpé en jours ouvrés par mois calendaire avec cette formule
important (choisir l'année en cellule b3)(affiché à l'ouverture 2020, choisir 2019)
Avancé (BB Code):
=SIERREUR(SI(ET($B5>=D$1;$C5<=D$2);NB.JOURS.OUVRES.INTL($B5;$C5;LISTE!$E$2;ferie);SI(ET(ANNEE($C5)*MOIS($C5)<>ANNEE(D$1)*MOIS(D$1);ANNEE($B5)*MOIS($B5)=ANNEE(D$1)*MOIS(D$1);$B5<D$2);NB.JOURS.OUVRES.INTL($B5;FIN.MOIS($B5;0);LISTE!$E$2;ferie);SI(ET(ANNEE($B5)*MOIS($B5)<>ANNEE(D$1)*MOIS(D$1);ANNEE($C5)*MOIS($C5)=ANNEE(D$1)*MOIS(D$1);$C5<D$2);NB.JOURS.OUVRES.INTL(FIN.MOIS($C5;-1)+1;$C5;LISTE!$E$2;ferie);SI(ET($B5<D$1;$C5>D$2);NB.JOURS.OUVRES.INTL(D$1;D$2;LISTE!$E$2;ferie);""))));"")
cordialement
galougalou
 
Ce message a été identifié comme étant une solution!

Fichiers joints

Dernière édition:

adie35

XLDnaute Nouveau
Merci beacoup, c'est exactement ce que je cherchais.
Explications très claires j'ai réussi à l'adapter à mon fichier.
Encore merci
Bonjour adie35; bonjour le fil, bonjour le forum
précision : les jours ouvrés , suppose samedi dimanche et fériés, donc formule NB.JOURS.OUVRES. pour une autre déclinaison préférer la formule nb jours ouvres intl qui permet de choisir les jours de fermeture

dans le classeur la feuille liste,
-se trouve les jours fériés par formule (supprimer ceux travaillé, comme lundi de pentecote, rajouter les jours fériés propre à votre région (ex st nicolas))
-se trouve en cellule e2 le choix des jours de fermeture

dans la feuille1 l'intervalle de date est découpé en jours ouvrés par mois calendaire avec cette formule
important (choisir l'année en cellule b3)(affiché à l'ouverture 2020, choisir 2019)
Avancé (BB Code):
=SIERREUR(SI(ET($B5>=D$1;$C5<=D$2);NB.JOURS.OUVRES.INTL($B5;$C5;LISTE!$E$2;ferie);SI(ET(ANNEE($C5)*MOIS($C5)<>ANNEE(D$1)*MOIS(D$1);ANNEE($B5)*MOIS($B5)=ANNEE(D$1)*MOIS(D$1);$B5<D$2);NB.JOURS.OUVRES.INTL($B5;FIN.MOIS($B5;0);LISTE!$E$2;ferie);SI(ET(ANNEE($B5)*MOIS($B5)<>ANNEE(D$1)*MOIS(D$1);ANNEE($C5)*MOIS($C5)=ANNEE(D$1)*MOIS(D$1);$C5<D$2);NB.JOURS.OUVRES.INTL(FIN.MOIS($C5;-1)+1;$C5;LISTE!$E$2;ferie);SI(ET($B5<D$1;$C5>D$2);NB.JOURS.OUVRES.INTL(D$1;D$2;LISTE!$E$2;ferie);""))));"")
cordialement
galougalou
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas