Application mise en forme conditionnelle

guigui4901

XLDnaute Junior
Bonjour à tous !

Je suis entrain de remettre d'aplomb l'ensemble de nos docs de travail et de cost control sur mes établissements.
Je mets en PJ le doc pour aider.
J'ai donc dans le doc une feuille par fournisseur et dans chaque feuille un état de suivi des tarifs unitaires proposés (pour vérifier l'évolution des prix de tel ou tel article).
J'ai sur chaque ligne en début de tableau le coût moyen de chaque article.
Je souhaite que la cellule de prix unitaire change en fonction de la moyenne : si le prix unitaire à une date D est inférieur à la moyenne (j'achète moins cher), alors la cellule est verte avec écriture en gras vert. Si le prix unitaire à la date D est supérieur... cellule en rouge pale avec écriture rouge gras.
La difficulté est évidement le nombre de colonnes du tableau....
Je ne comprends pas pourquoi ma Mise en forme C n'est pas bonne... Est-ce que vous pouvez regarder ?
Avez-vous une autre solution?

Merci de votre aide et du temps que vous passez sur le travail....

Belle journée à tous !

Guillaume
 

Fichiers joints

Dranreb

XLDnaute Barbatruc
Bonjour/
Les règles étant définies à partir de la ligne 3, la colonne F de la ligne en cours c'est =$F3 et non =F4.
 

job75

XLDnaute Barbatruc
Bonsoir guigui4901, Bernard, mapomme,

Formule matricielle pour la moyenne en F3 du fichier joint :

=SIERREUR(MOYENNE(SI(ESTNUM(G3:PN3)*MOD(COLONNE(G3:PN3);2);G3:PN3));"")

Formules de la MFC sur les colonnes entières G : PN :

=(LIGNE()>2)*ESTNUM(G1)*MOD(COLONNE();2)*(G1>=$F1)
=(LIGNE()>2)*ESTNUM(G1)*MOD(COLONNE();2)*(G1<$F1)

A+
 

Fichiers joints

Dernière édition:

guigui4901

XLDnaute Junior
Merci beaucoup à tous !

En effet la formule est beaucoup plus simple et plus intelligente.... sans compter le temps gagné bien entendu...
Toujours aussi génial ce forum.... Un jour Je m'y mettrai vraiment à fond car Excel me plait vraiment beaucoup !!!

Bon dimanche à tous et encore merci pour le coup de main
 

Dranreb

XLDnaute Barbatruc
$F$1 reste comme ça pour toutes les lignes tandis que $F1 se transforme en $F2, $F3 etc. pour les lignes suivantes.
 

guigui4901

XLDnaute Junior
Autre petite question en essayant de comprendre les formules que vous avez faites : à quoi servent les {} en début et fin de formule ?

Est-ce que ça peut expliquer que si je modifie cette formule :

=SIERREUR(MOYENNE(SI(ESTNUM(G3:pN3)*MOD(COLONNE(G3:pN3);2);G3:pN3));"")

en :

=SIERREUR(MOYENNE(SI(ESTNUM(G3:ABH3)*MOD(COLONNE(G3:ABH3);2);G3:ABH3));"")

Le calcul de ma moyenne ne fonctionne plus ?


Merci de votre aide :)
bonne soirée !

Guillaume
 
Dernière édition:

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonsoir @guigui4901,
Autre petite question en essayant de comprendre les formules que vous avez faites : à quoi servent les {} en début et fin de formule ?

Est-ce que ça peut expliquer que si je modifie cette formule :

=SIERREUR(MOYENNE(SI(ESTNUM(G3:pN3)*MOD(COLONNE(G3:pN3);2);G3:pN3));"")

en :

=SIERREUR(MOYENNE(SI(ESTNUM(G3:ABH3)*MOD(COLONNE(G3:ABH3);2);G3:ABH3));"")

Le calcul de ma moyenne ne fonctionne plus ?
Très certainement oui.

job75 vous a précisé que cette formule était une formule matricielle. Les formules matricielles sont un type particulier de formules. Dans le fichier que j'avais joint, vous trouverez comment valider les formules matricielles. J'avais prévu le coup ! ;)
 

guigui4901

XLDnaute Junior
Bonsoir @guigui4901,


Très certainement oui.

job75 vous a précisé que cette formule était une formule matricielle. Les formules matricielles sont un type particulier de formules. Dans le fichier que j'avais joint, vous trouverez comment valider les formules matricielles. J'avais prévu le coup ! ;)

C'est bien ce qui me semble... je suis un peu perdu pour le coup. :(

Merci en tout cas :)
 

Discussions similaires


Haut Bas