Contenu récent par pkerga

  1. P

    XL 2013 Optimisation VBA copie csv vers excel

    bonjour je débute en VBA et j'ai besoin d'aide pour optimiser mon code et le parfaire. Voici le projet : 1 fichier Excel "Tension" avec 2 feuilles ("ES" et "resultats"). 1 Csv à aller chercher et à insérer dans "ES" (70 000 lignes et 300 calculs par ligne...) 1 - stopper les calculs...
  2. P

    modifier carte dynamique de la France selon pourcentage

    Re : modifier carte dynamique de la France selon pourcentage par ailleurs je me rends compte qu'on pourrait automatiser encore l'affaire en calculant le G2, le numéro du départemnt le plus utiliser en J...
  3. P

    modifier carte dynamique de la France selon pourcentage

    Re : modifier carte dynamique de la France selon pourcentage merci, ca marche au poil?=. restent 2 problèmes : - j'ai du modifier la formule pour trouver combien de personnes sont hors 56 (nombre de valeur sur colonne J moins une moins la valeur max de la colonn E) car les resultats sont...
  4. P

    modifier carte dynamique de la France selon pourcentage

    Re : modifier carte dynamique de la France selon pourcentage merci, ca marche tres bien seule precision, je vais etre amenée à etudier 3 autres depatrements (29, 22 et 35). Comment faire varier les formules de la colonne C en fonction du dept étudié (par exemple choix dans une liste en G11) ?
  5. P

    modifier carte dynamique de la France selon pourcentage

    bonjour j'ai récupéré sur le forum une carte dynamique de la France que j'essaye de modifier pour mes besoins. Je cherche à montrer l'origine géographique (département) des personnes prises en charge dans le morbihan (56). Mon problème se situe sur les couleurs qui sont gérées actuellement...
  6. P

    concatener 3 colonnes en VBA

    bonjour j'ai débuté une petite formule VBA dans mon classeur pour copier des colonnes de ma feuile "base" vers ma feuille "heures" dans les colonnes A, B et C. L'idée est de les concatener tous les 3 dans la colonne D afin que je puisse les comparer et compter les doublons (ce qui est fait en...
  7. P

    comparaison base donnée et codes postaux

    Re : comparaison base donnée et codes postaux ok, je vais essayer mon souci est que je suis amené à changer de base de données très souvent, avec des tailles variables (le fichier sert à analyser la cohérence de la base de données) et que je souhaite éviter de devoir réécrire des formules ou...
  8. P

    comparaison base donnée et codes postaux

    Re : comparaison base donnée et codes postaux j'avais pensé à ça mais j'ai aussi besoin de les dénombrer (en fait, il ne doit pas y avoir de pb et cela doit donner "0" comme resultats).
  9. P

    comparaison base donnée et codes postaux

    bonjour, j'ai une base de donnée (feuille BASE) avec en colonnes D et E des codes postaux et des villes censées corespondre. J'ai une liste fiable (feuille CP) avec les villes et les codes postaux. Je cherche une macro me permettant : - de lister les erreurs (codes postale et ville non...
  10. P

    varaible pour numero ligne de case

    Re : varaible pour numero ligne de case merci du coup j'ai essayé d'introduire une formule de ce type dans le fichier dont j'ai besoin (le vrai) et je ne m'en sors pas... Dans mon fichier ci dessous, dans la feuille MEP, la case I9 fait reference à "2146", le chiffre venant de la case B6 sur...
  11. P

    varaible pour numero ligne de case

    bonjour, je cherche à créer une formule et pas moyen de réussir, je pense qu'il faut utiliser INDEX mais... Soit un tableau D2 à F7. B4 est la somme d'une ligne du tableau =SOMME(D"B2":F"B2") ou la ligne est choisie en B2. Ainsi si B2 est égal à 3, B4=SOMME(D3:F3). COmment automatisé ...
  12. P

    etude base de données

    Re : etude base de données bonjour, j'ai inclus une macro que j'ai trouvée sur internet qui me liste les doublons en prenant en compte en seule colonne (la H). Y a t'il moyen de prendre en compte plusieurs colonnes (genre H et Q) ?
  13. P

    etude base de données

    Re : etude base de données merci, je vais bosser sur le domaine. Pour autant et surtout à titre instructif, il y a une solution directe à mes problemes ? Cordialement
  14. P

    etude base de données

    bonjour - j'ai un fichier permettant l'étude d'une base de donnée se trouvant dans la feuille "base". j'utilise ce fichier en remplacant les données de la feuille base par d'autres données et en regardant les resutats sur les autres feuilles. Mon probleme est que je suis amené à étudier des...
  15. P

    aide sur TCD

    bonsoir, j'ai besoin d'un peu d'aide par rapport à l'utilsation de tableaux croisés dynamiques. J'ai une base de données avec des dates d'entrées, des horaires d'entrées et des durées de passages. J'arrive à faire un tableau permettant de savoir le nombre d'entrée par heures pour les samedi...
Haut Bas