1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

Somme de plusieurs colonnes avec une seule colonne de critère

Discussion dans 'Forum Excel' démarrée par meritein, 13 Août 2017.

  1. meritein

    meritein XLDnaute Nouveau

    Inscrit depuis le :
    20 Août 2005
    Messages :
    34
    "J'aime" reçus :
    1
    Bonjour,
    j'y arrive pas. Je souhaite faire la somme de chiffres situés dans plusieurs colonnes avec des critères dans une seule colonne. J'ai regardé somme.si, somme.si.ens sommeprod bdsomme, rien n'a fonctionné. Voudriez-vous m'aider svp à trouver la formule magique ? Merci d'avance.
    Je joins un exemple de tableau en précisant que les zones de sélection sont plus étendues que les zones remplies (en d'autres termes la zone critère va de A2 à A33 et la zone de chiffres à sommer de B2 à M33).
     

    Pièces jointes:

  2. Jocelyn

    Jocelyn XLDnaute Barbatruc

    Inscrit depuis le :
    26 Septembre 2005
    Messages :
    6465
    "J'aime" reçus :
    258
    Sexe :
    Masculin
    Habite à:
    Poitiers (Vienne)
    Utilise:
    Excel 2000 (PC)
    Bonjour le Forum,
    Bonjour merirein,

    pas bien sur de ton besoin mais un essai quand même

    Cordialement
     

    Pièces jointes:

  3. Patrice33740

    Patrice33740 XLDnaute Occasionnel

    Inscrit depuis le :
    6 Août 2013
    Messages :
    214
    "J'aime" reçus :
    17
    Sexe :
    Masculin
    Habite à:
    Arès
    Utilise:
    Excel 2007 (PC)
    Bonjour,

    A revoir
     
  4. meritein

    meritein XLDnaute Nouveau

    Inscrit depuis le :
    20 Août 2005
    Messages :
    34
    "J'aime" reçus :
    1
    Jocelyn, merci pour cette réponse rapide qui donne le résultat escompté à ceci près : dans les zones sélectionnées de sommeprod je souhaiterai y inclure des cellules vides. Est-ce possible ? Dans ton exemple, il n'y a pas de cellules vides sélectionnées.
     
  5. Jocelyn

    Jocelyn XLDnaute Barbatruc

    Inscrit depuis le :
    26 Septembre 2005
    Messages :
    6465
    "J'aime" reçus :
    258
    Sexe :
    Masculin
    Habite à:
    Poitiers (Vienne)
    Utilise:
    Excel 2000 (PC)
    re
    Bonjour Patrice 33740,

    A priori dans la plage d'addition j'ai bien des cellules vide puisque j'ai pris jusqu'a la colonne M et que de la colonne F à M les cellules sont vides.

    à te lire

    Cordialement
     
  6. meritein

    meritein XLDnaute Nouveau

    Inscrit depuis le :
    20 Août 2005
    Messages :
    34
    "J'aime" reçus :
    1
    Etrange ! Voici la formule que j'ai écrite
    =SOMMEPROD($E$79:$P$286*($B$79:$B$286=Q20)) cela me retourne #VALEUR!.
    J'arrive pas à voir si j'ai une erreur de syntaxe.
     
  7. job75

    job75 XLDnaute Barbatruc

    Inscrit depuis le :
    15 Mai 2008
    Messages :
    22844
    "J'aime" reçus :
    1619
    Sexe :
    Masculin
    Habite à:
    Paris
    Utilise:
    Excel 2013 (PC)
    Bonjour meritein, Jocelyn, Patrice,

    Avec SOMME.SI on peut utiliser des plages illimitées, formule en P2 :
    Code (Text):
    =SOMMEPROD(SOMME.SI(A:A;O2;DECALER(A:A;;COLONNE(B:M)-1)))
    Fichier joint.

    A+
     

    Pièces jointes:

  8. Jocelyn

    Jocelyn XLDnaute Barbatruc

    Inscrit depuis le :
    26 Septembre 2005
    Messages :
    6465
    "J'aime" reçus :
    258
    Sexe :
    Masculin
    Habite à:
    Poitiers (Vienne)
    Utilise:
    Excel 2000 (PC)
    re,

    A priori je ne vois pas d'erreur de syntaxe quand tu parles de cellule vide se sont de vrai cellules vide ou des cellules qui contiennent quelque chose comme ""

    A tester une autre écriture

    Code (Text):
    =SOMMEPROD(($B$79:$B$286=Q20)*(ESTNUM($E$79:$P$286))*1;$E$79:$P$286)
    et autrement une autre formule attention elle est matricielle a valider par les touche CTRL, Maj (au dessus de CTRL) et entrée

    Code (Text):
    =SOMME(si(($B$79:$B$286=Q20)*(ESTNUM($E$79:$P$286));$E$79:$P$286))
    Cordialement

    EDIT Bonjour job75
     
  9. meritein

    meritein XLDnaute Nouveau

    Inscrit depuis le :
    20 Août 2005
    Messages :
    34
    "J'aime" reçus :
    1
    Effectivement, le problème venait des cellules soi-disant vides qui, en réalité, étaient sans résultat car la formule retournait "". Bien vu. Les 2 codes de texte fonctionnent.
    Merci beaucoup et bonne soirée.
     
  10. mapomme

    mapomme XLDnaute Barbatruc

    Inscrit depuis le :
    1 Novembre 2011
    Messages :
    4281
    "J'aime" reçus :
    616
    Sexe :
    Masculin
    Habite à:
    Angers
    Utilise:
    Excel 2010 (PC)
    Bonjour à tous :),
    Une autre formule :
    Code (Text):
    =SOMMEPROD(ESTNUM(B$2:M$30)*( A$2:A$30=O2);B$2:M$30)
    edit : je présente mes excuses les plus sincères :oops: à jocelyn dont le message m'avait échappé :confused: et dont la formule est analogue à la formule de ma pomme.
     

    Pièces jointes:

    Dernière édition: 14 Août 2017
  11. job75

    job75 XLDnaute Barbatruc

    Inscrit depuis le :
    15 Mai 2008
    Messages :
    22844
    "J'aime" reçus :
    1619
    Sexe :
    Masculin
    Habite à:
    Paris
    Utilise:
    Excel 2013 (PC)
    Bonjour à tous,

    Oui ma pomme et si les textes sur B2:M30 ne sont que des textes vides "" :
    Code (Text):
    =SOMMEPROD(( A$2:A$30=O2)*(0&B$2:M$30))
    Bonne journée.
     
    mapomme aime votre message.

Partager cette page