1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

employés present entre 2 dates

Discussion dans 'Forum Excel' démarrée par Timoth', 14 Septembre 2018.

  1. Timoth'

    Timoth' XLDnaute Nouveau

    Inscrit depuis le :
    14 Septembre 2018
    Messages :
    4
    "J'aime" reçus :
    0
    Utilise:
    Excel 2016 (PC)
    Bonjour,
    sur un tableau regroupant l'ensemble des salariés présent dans l'entreprise, je cherche à trouver le nombre de salariés présent entre 2 dates.
    Le problème est que comme données de date je n'ai que la date de début de contrat et la date de fin de contrat.
    Pour les salariés toujours en contrat je n'ai donc pas de date de sortie.
    est ce possible et comment?
    merci beaucoup pour votre aide.
     
  2. Chargement...

    Discussions similaires - employés present entre Forum Date
    XL 2007 Tableau Calendaire heures de travail des employés Forum Excel 28 Avril 2018
    XL 2016 Tableau de congés employés Forum Excel 14 Janvier 2018
    XL 2016 Automatiser analyse d'un planning d'employés Forum Excel 7 Janvier 2018
    XL 2016 Horaires de travail de plusieurs employés Forum Excel 3 Décembre 2017
    XL 2013 Comment automatiser l'affichage des salaires de base des employés à l'aide d'une fonction VBA Excel Forum Excel 19 Juin 2017

  3. chris

    chris XLDnaute Barbatruc

    Inscrit depuis le :
    21 Février 2005
    Messages :
    11033
    "J'aime" reçus :
    594
    Habite à:
    près de St Quentin en Yvelines/ Excel 2010 et 2016
    Utilise:
    Excel 2010 (PC)
    Bonjour
    Oui avec un SI on peut tester la date de fin et la considérer comme ta date limite.

    Il faudrait plus de détails pour te donner une formule précise.

    Utilises-tu actuellement NB.SI, SOMMPROD ou autre
     
  4. Timoth'

    Timoth' XLDnaute Nouveau

    Inscrit depuis le :
    14 Septembre 2018
    Messages :
    4
    "J'aime" reçus :
    0
    Utilise:
    Excel 2016 (PC)
    merci, mais j'ai déja essayé mais comme la date de sortie est vide, cela m'indique une erreur.
    ci joint exemple
     

    Pièces jointes:

  5. chris

    chris XLDnaute Barbatruc

    Inscrit depuis le :
    21 Février 2005
    Messages :
    11033
    "J'aime" reçus :
    594
    Habite à:
    près de St Quentin en Yvelines/ Excel 2010 et 2016
    Utilise:
    Excel 2010 (PC)
    Re

    Pour ceux qui étaient là durant toute la période
    Code (Text):
    =SOMMEPROD((B3:B15<=C17)*((C3:C15>=E17)+(C3:C15="")))
    Si présence partielle
    Code (Text):
    =SOMME(SI((SI(C3:C15="";$E$17;C3:C15)-SI(B3:B15<$C$17;$C$17;B3:B15))>0;1;0))
    en matriciel donc à valider par Ctrl Shift Entrée
     
    Dernière édition: 14 Septembre 2018
  6. Timoth'

    Timoth' XLDnaute Nouveau

    Inscrit depuis le :
    14 Septembre 2018
    Messages :
    4
    "J'aime" reçus :
    0
    Utilise:
    Excel 2016 (PC)
    merci beaucoup pour la réponse.
    mais cela m’enlève totalement les personne qui ne sont pas présentes sur l'ensemble de la période. hors elles étaient bien présente a un moment
    autre problème, j'aimerais connaitre le temps de présence global sur la période indiqué.
    ci joint le tableau complete
     

    Pièces jointes:

  7. chris

    chris XLDnaute Barbatruc

    Inscrit depuis le :
    21 Février 2005
    Messages :
    11033
    "J'aime" reçus :
    594
    Habite à:
    près de St Quentin en Yvelines/ Excel 2010 et 2016
    Utilise:
    Excel 2010 (PC)
    Bonjour

    La seconde formule tient tient compte d'une présence sur une partie de la période, l'as-tu essayée ?
     
  8. JHA

    JHA XLDnaute Barbatruc

    Inscrit depuis le :
    15 Juillet 2006
    Messages :
    7337
    "J'aime" reçus :
    350
    Sexe :
    Masculin
    Habite à:
    Dunkerque
    Utilise:
    Excel 2013 (PC)
    Bonjour à tous,

    A tout hasard,

    JHA
     

    Pièces jointes:

  9. Timoth'

    Timoth' XLDnaute Nouveau

    Inscrit depuis le :
    14 Septembre 2018
    Messages :
    4
    "J'aime" reçus :
    0
    Utilise:
    Excel 2016 (PC)
    merci pour vos réponses.
    j'ai tester l'ensemble des solutions mais aucune ne fonctionne vraiment.
    je cherche toujours de mon coté...
    au cas où, j'utilise XL 2016
     
  10. chris

    chris XLDnaute Barbatruc

    Inscrit depuis le :
    21 Février 2005
    Messages :
    11033
    "J'aime" reçus :
    594
    Habite à:
    près de St Quentin en Yvelines/ Excel 2010 et 2016
    Utilise:
    Excel 2010 (PC)
    Re à tous

    Concernant les présents sur une partie de la période, les diverses solutions donnent 13 : tu comptes en trouver combien et si différent de 13 explique ta logique sinon on en sera encore au même point à Noël car "aucune ne fonctionne vraiment" ne signifie pas grand chose...
     

Partager cette page