Contenu récent par Lolote83

  1. L

    Résolu Format de date pour créer un TCD

    Salut à tous Voir ton fichier en retour. Le problème est que ta colonne B est en format texte J'ai donc rajouté une nouvelle colonne @Edit Jocelyn @+ Lolote83
  2. L

    Résolu Récupération après dernier antislash

    Re salut à tous, Une compilation des réponses ici car DjiDji n°1 n'était pas bonne @+ Lolote83
  3. L

    Résolu Récupération après dernier antislash

    Salut à tous, Le temps de rafraichir et me voici déjà à la traine. Voici donc mon code avant de jeter un coup d’œil aux vôtres Formule personnalisée. @+ Lolote83
  4. L

    XL 2016 Formule excel en VBA ?

    Bonjour BARAZOUTI, Effectivement, c'est peut être préférable @+ Lolote83
  5. L

    XL 2013 Extraction de données en fonction d'une date

    Re salut Jean-Jack, Voici donc ton fichier en retour en incluant donc l'année dans la partie vente du mois @+ Lolote83
  6. L

    Autres Extraire des lignes de données dans une autre feuille

    Re salut MOUA, D'après tes dires : Pour les autres classes, il suffit de duppliquer un onglet existant et de changer la valeur de la cellule de critère (cellule E2) donc ici se sera pour - Classe 5E écrire en E2=5E - Classe 5F écrire en E2=5F. Sinon, je ne pense pas que la multiplicité des...
  7. L

    XL 2013 Extraction de données en fonction d'une date

    Re salut, N'ayant pour base qu'une toute petite partie, il m'était difficile de connaitre exactement ce que tu souhaitais à l'avance. Je ne suis pas devin ..... Donc pour l'année (ex 2019), on pourrait avoir en cellule I2 l'année inscrite en dur De fait, la formule en I5 serait...
  8. L

    XL 2013 Extraction de données en fonction d'une date

    Salut JEAN-JACK, Voici ton fichier en retour. Pas de VBA mais formules De plus un onglet TCD @+ Lolote83
  9. L

    Autres Extraire des lignes de données dans une autre feuille

    Salut MOUA, Voici ton fichier en retour. Une macro basée sur les filtrtes elaborés fait ce que tu cherches Ne pas supprimer les cellules E1 et E2 = critères Un clic sur le bouton @+ Lolote83
  10. L

    XL 2010 copier une cellule suivant texte d'une autre cellule

    Salut, En C2 =SI(ANNEE($B2)=2019;$A2;0) puis tirer vers le bas En D2 =SI(ANNEE($B2)=2020;$A2;0) puis tirer vers le bas Cordialement @+ Lolote83
  11. L

    XL 2010 VBA excel: colorer la ligne pour chaque cellule qui a plus qu'une valeur dans une autre colonne

    Salut, Sans VBA mais peut être avec une simple MFC (Mise en Forme Conditionnelle) @+ Lolote83
  12. L

    Résolu Filtre TCD en fonction d'une Cellule

    Salut à tous, Une solution mais celle de Chris reste à mon avis la plus appropriée Mettre ce code dans la partie Worksheet_Change de l'onglet Feuille de Saisie Private Sub Worksheet_Change(ByVal Target As Range) If Intersect(Target, Range("B6")) Is Nothing Then Exit Sub With...
  13. L

    XL 2016 Executer une procédure pour chaque textbox

    Salut DODINEAU, Si tu effectues l'opération doucement, tu comprendras mieux pourquoi il y a ce phénomène Exemple : Lors du 1er double-clic, un message t'informe que l'on execute une procédure UNIQUE De là, tu es obligé de cliquer sur le bouton OK du MessageBox Un nouveau clic sur un nouveau...
  14. L

    XL 2013 enlever (N°) dans une colonne des données ( VBA ) automatique

    Re salut, Avec ce nouveau code, cela devrait faire l'affaire Sub Test() Dim xDerlig As Integer Dim xCell As Variant Dim xDecoupe As Variant Dim xCpt As Variant Application.ScreenUpdating = False Application.Calculation = xlManual With Sheets("Feuil2")...
  15. L

    XL 2013 enlever (N°) dans une colonne des données ( VBA ) automatique

    Salut, Je regarde tout ceci demain. @+ Lolote83
Haut Bas