[XLS03] Fonction percentile avec condition ??

michaelknight00

XLDnaute Nouveau
Bonjour à tous,

J'aimerais utiliser la fonction percentile dans un tableau, mais appliquer une condition.
Par exemple, je voudrais calculer les 5% de valeurs du tableau A1:A100, si et seulement la valeur correspondante dans la colonne B est égale à 12...

J'ai pensé au calcul matriciel, mais je flanche...
J'espère avoir été clair !

Merci d'avance !
 

JCGL

XLDnaute Barbatruc
Re : [XLS03] Fonction percentile avec condition ??

Bonjour à tous,

Peux-tu essayer avec dans une cellule :
Code:
=SOMME.SI(B1:B100;12;A1:A100)*0.05
A+ à tous
 

hoerwind

XLDnaute Barbatruc
Re : [XLS03] Fonction percentile avec condition ??

Bonjour,

Je suppose que tu travailles en anglais, en français c'est la fonction CENTILE().

La seule solution que j'ai trouvée est de créer une plage annexe qui trie la plage initiale sur base de la condition en colonne B, puis d'appliquer la fonction sur cette nouvelle plage.
J'ai bien essayé avec une matricielle mais sans parvenir à un résultat.
 

Monique

XLDnaute Barbatruc
Re : [XLS03] Fonction percentile avec condition ??

Bonjour,

à essayer :

=CENTILE(SI(B1:B100=12;A1:A100);0,05)

(à valider par ctrl, maj et entrée)
 

michaelknight00

XLDnaute Nouveau
Re : [XLS03] Fonction percentile avec condition ??

Hello,
Merci à vous trois !

JCGL --> Je pense que ça fonctionne, mais je suis un fana des fonctions matricielles :)
Hoerwind --> Trop compliqué car je vais fournir le fichier à quelqu'un qui maîtrise peu excel
Monique --> Merci ! C'est exactement ce sur quoi je voulais arriver !

A bientôt pour de nouvelles formules ;)
A+
 

tprlechef

XLDnaute Nouveau
Re : [XLS03] Fonction percentile avec condition ??

Bonjour à tous je relance ce vieux sujet...

J'ai la meme problèmatique et en cherchant je suis tombé sur le sujet de michaelknight00

J'ai donc appliqué la formule conseiller par Monique.

=CENTILE(SI(B5:B1000="Closed";AL5:AL1000);0,95)

Seul problème c'est qu'il me prend toute les valeur de AL5:AL1000 et non pas uniquement les valeurs ou dans la colonne B il y a Closed...

Quelqu'un a une idée?
 

Discussions similaires


Haut Bas