[XLS 2003] Créer fonction "contain"

michaelknight00

XLDnaute Nouveau
Hello à tous,
J'ai un tableau à deux entrées, qui contient des formules qui renvoient rien ou bien "v".

J'aimerais pouvoir tracer quand un "v" apparait plusieurs fois sur une même ligne, afin de ne l'écrire qu'une fois.
Par exemple, si j'ai un "v" en A1, et qu'en D1 le résultat de ma formule me donne aussi un "v", que ça ne l'affiche pas...

Voici ce que j'ai essayé (en vain) : Si je me situe en D1 par exemple
=IF(ISERROR(FIND("v";A1:C1));IF(Sheet2!D1="good";"v";"");"");"")

Qu'en pensez-vous ?
Merci d'avance :)
 

job75

XLDnaute Barbatruc
Re : [XLS 2003] Créer fonction "contain"

Bonjour,

Essayer en D1 :

Code:
=IF(ISNA(MATCH("v",$A1:C1,0))*(Sheet2!D1="good"),"v","")
Cette formule peut être copiée sur toute la ligne, sauf en A1...

Nota : j'ai mis des virgules à la place des points-virgules, sauf erreur il en est ainsi dans la version anglaise, non ???

A+
 

michaelknight00

XLDnaute Nouveau
Re : [XLS 2003] Créer fonction "contain"

Hello,
Merci pour ta réponse :)
Mais elle ne fonctionne pas comme je le souhaite.
Je suis donc parti sur une solution moins belle mais qui marche nikel ! En remplaçant les "v" par des 1...
=IF(SUM($A1:C1)=0;IF(Sheet2!D1="good";1;"");"")
Merci à plus !
 

ROGER2327

XLDnaute Barbatruc
Re : [XLS 2003] Créer fonction "contain"

Bonjour
Vous pouvez garder "v" avec ça :
Code:
=SI(NB.SI($A2:C2;"v");"";SI(Feuil2!D2="bon";"v";""))
que vous mettrez dans la langue vous voudrez.
En A2, mettre seulement :
Code:
=SI(Feuil2!A2="bon";"v";"")
ROGER2327
 

Discussions similaires


Haut Bas