[XL2010] Compter les "x" d'une matrice si "Valeur" dans dans une autre colonne

Julien_H

XLDnaute Nouveau
Bonjour à tous,

Je suis bloqué depuis hier sur une formule qui marche, mais me retourne #VALUE.

Le problème:
J'ai une matrice B1:E150 dans laquelle les cellules on des "x" ou rien.
Dans ma colonne A1:A150, j'ai des départements "Finance", "Orga", "Sinistre".

Je voudrais compter le nombre de "x" dans ma matrice quand j'ai le département "Finance", puis compter le nombre de "x" quand j'ai le département "Orga", etc.

J'ai pour le moment essayer (j'ai Excel en anglais), mais ça ne fonctionne pas:

Code:
=COUNTIFS($B$1:$E$150;"x";$A$1:$A$150;"Finance")
J'ai tendance à penser que COUNTIFS ne gère pas les matrices.

N'hésitez pas à revenir vers moi si vous avez le temps.

Merci à toute la communauté!

Julien.
 
D

Denis

Guest
Re : [XL2010] Compter les "x" d'une matrice si "Valeur" dans dans une autre colonne

Bonjour Julien, le forum
essais ceci (en anglais Sommeproduct je pense)

=SOMMEPROD((A1:A150="Finance")*(B1:E150="x")*1)
Bon courage et à+
Denis
 

Julien_H

XLDnaute Nouveau
Re : [XL2010] Compter les "x" d'une matrice si "Valeur" dans dans une autre colonne

Ca marche!
Merci beaucoup Denis.

Bien à toi.
 
Haut Bas