[XL 2003] Calcul d'une moyenne en omettant certaines valeurs

grant_lee

XLDnaute Nouveau
Bonjour,

Je travaille sur des valeurs pour lesquelles je calcule la moyenne ainsi que l'écart type.
Je définis ensuite des bornes inférieures et supérieures correspondant respectivement à la moyenne-l'écart type et à la moyenne+l'écart type.

Je souhaiterai recalculer une nouvelle moyenne "corrigée" qui ne prendrait pas en compte les valeurs situées hors des bornes précédemment définies.

Sur l'exemple ci-joint, il faudrait donc recalculer une moyenne en omettant les cellules en rouge. Je précise que le nombre total de valeurs est variable.
 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
Re : [XL 2003] Calcul d'une moyenne en omettant certaines valeurs

Bonjour le Forum,
Bonjour grant_lee, JCGL :),

une autre solution sur le fichier de JCGL, pour que tu ais les 2, ma formule est matricielle à validée par les touches CTRL, Maj et entrée

Cordialement
 

Fichiers joints

R@chid

XLDnaute Barbatruc
Re : [XL 2003] Calcul d'une moyenne en omettant certaines valeurs

Bonjour @ tous,
Salut JCGL, Salut Jocelyn,
Code:
=MOYENNE(SI((C3:C13>=MOYENNE(C3:C13)-ECARTYPE(C3:C13))*(C3:C13<=MOYENNE(C3:C13)+ECARTYPE(C3:C13));C3:C13))
@ valider par Ctrl+Maj+Entree
@ micalement
 
Dernière édition:

Discussions similaires


Haut Bas