XL 2010 Vba

Konte94

XLDnaute Nouveau
Salut aidez moi à résoudre cet exercice ci-dessous :

Ecrire une fonction à trois paramètres ( a, b et defaut) qui retourne le minimum de deux entiers naturels a et b si et seulement si aucun n'est nul.
Si a (respectivement b) vaut 0, la fonction doit retourner b (respectivement a).
Si a et b sont nuls, la fonction doit retourner le 3ème paramètre (defaut)
(Faire une application sur une feuille Excel)
 

patricktoulon

XLDnaute Barbatruc
bonjour Laurent3372
une autre façon de l’écrire

comme tu l'écrirais en formule
VB:
Function Min_non_null(a As Integer, b As Integer, defaut As Integer) As Integer
' Default peut être du texte
     Min_non_null = IIf(a + b = 0, -1, IIf(a = 0 Or b = 0, a + b, WorksheetFunction.Min(a, b)))
End Function
la formule
=SI(A1+B1=0;-1;SI(OU(A1=0;B1=0);A1+B1;MIN(A1:B1)))

tu peux mettre ta formule dans un name et te faire une fonction aussi
 

Fichiers joints

Dernière édition:

Konte94

XLDnaute Nouveau
bonjour Laurent3372
une autre façon de l’écrire

comme tu l'écrirais en formule
VB:
Function Min_non_null(a As Integer, b As Integer, defaut As Integer) As Integer
' Default peut être du texte
     Min_non_null = IIf(a + b = 0, -1, IIf(a = 0 Or b = 0, a + b, WorksheetFunction.Min(a, b)))
End Function
la formule
=SI(A1+B1=0;-1;SI(OU(A1=0;B1=0);A1+B1;MIN(A1:B1)))

tu peux mettre ta formule dans un name et te faire une fonction aussi
Salut Laurent j'ai essayé de résoudre cet exercice ci-dessous mais le nombre de ligne et de colonne est de 5. Pouvez vous m'aider svp à l'élargir pour n lignes et m colonnes.
Je vous envoie l'énoncé et la pièce jointe.

1°) Faire un programme VBA qui génère sur une feuille Excel un tableau de n lignes et de m colonnes contenant les nombres multiples du chiffre 3. Exple 0, 3, 6, 9…
Les tailles n et m sont récupérées par le programme.
 

Fichiers joints

Konte94

XLDnaute Nouveau
Merci beaucoup Laurent
Salut à toi, Konte
Ce n'est pas vraiment aider que de fournir une solution toute faite, surtout en réponse à une demande formulée aussi poliment. Mais enfin, voilà.

Cordialement,
--
LR
Salut Larent vérifiez pour moi svp si on peut élargir cette macro à n lignes et m colonnes.
Voici l'énoncé et la pièce jointe ci-dessous.

1°) Faire un programme VBA qui génère sur une feuille Excel un tableau de n lignes et de m colonnes contenant les nombres multiples du chiffre 3. Exple 0, 3, 6, 9…
Les tailles n et m sont récupérées par le programme.
 

Fichiers joints

Ikito

XLDnaute Occasionnel
Déjà répondu :

VB:
Function retourner(a As Integer, b As Integer, defaut As Integer)

If (a = 0) Then
    retourner = b
End If

If (b = 0) Then
    retourner = a
End If

If (a <> 0 And b <> 0) Then
    retourner = Application.Min(a, b)
End If

If (a = 0 And b = 0) Then
    retourner = defaut
End If

End Function
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas