[VBA] - Renvoi lettre d'une colonne

nico0007

XLDnaute Junior
Bonjour le forum,

Le titre de ma discussion n'est pas très parlant...
En fait j'aimerai juste pouvoir utiliser la lettre de la colonne que je spécifie. La commande "Cellule.column" me renvoit un chiffre. Etant donné que je réutilise cette donnée dans une autre fonction par le biais de cette commande:
Code:
Set maSelection = range(uneColonne & "9:" & uneColonne & Derligne)
UneColonne est un chiffre et donc maSelection est fausse...

Merci de votre aide
 

wilfried_42

XLDnaute Barbatruc
Re : [VBA] - Renvoi lettre d'une colonne

Bonjour

utilise cells au lieu de range

Code:
set maselection = range(cells(9,activecell.colum),cells(derligne, activecell.column))
 

CBernardT

XLDnaute Barbatruc
Re : [VBA] - Renvoi lettre d'une colonne

Bonjour nico0007, wilfried_42,


Essayes sans mettre de lettre du style :

Sub Macro1()
Dim maSelection As Range, UneColonne As Byte
UneColonne = Range("C1").Column
Set maSelection = Columns(UneColonne)
maSelection.Select
End Sub

Cordialement

Bernard
 

nico0007

XLDnaute Junior
Re : [VBA] - Renvoi lettre d'une colonne

Merci messieurs!!

Tout s'est bien passé. Je n'avais effectivement pas pensé à "cells"...:eek:

@ plus
 

ROGER2327

XLDnaute Barbatruc
Re : [VBA] - Renvoi lettre d'une colonne

Bonjour à tous.
Évidemment d'accord avec les solutions proposées. Donc, juste pour le plaisir :
Code:
Function DecAlph(c As Integer) As String
[COLOR="SeaGreen"]'   =SI(A1<703;SI(A1>26;CAR(ENT((A1-1)/26)+64);"")&SI(A1;CAR(MOD(A1-1;26)+65);"");"")[/COLOR]
    DecAlph = IIf(c < 703, IIf(c > 26, Chr((c - 1) \ 26 + 64), "") & _
        IIf(c, Chr(((c - 1) Mod 26) + 65), ""), "")
End Function

Function AlphDec(s As String) As Integer
[COLOR="SeaGreen"]'   =26*CODE(DROITE("@"&B1;2))+CODE(DROITE(DROITE("@"&B1;2);1))-1728[/COLOR]
    If Len(s) Then AlphDec = 26 * Asc(Right$("@" & s, 2)) + Asc(Right$(s, 1)) - 1728 Else AlphDec = 0
End Function
DecAlph prend un argument entier de 1 à 702 et renvoie une chaîne de caractères de "A" à "ZZ".
AlphDec fait l'inverse.​
Bonne journée !
ROGER2327
 

pierrejean

XLDnaute Barbatruc
Re : [VBA] - Renvoi lettre d'une colonne

bonjour a tous

Pour le fun egalement

Code:
Function lettre_col(n As Integer)
 lettre_col = Split(Cells(1, n).Address, "$")(1)
End Function
 

BenHarber

XLDnaute Occasionnel
Re : [VBA] - Renvoi lettre d'une colonne

Super formule pierrejean : je la glisse dans ma besaçe !
Merci,
BH
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas