Résolu VBA Copier/Coller couleur mise en forme conditionnelle

Roblochon

XLDnaute Accro
Bonjour,

C'est normal car dans votre procédure 'RangetoHTML'
Vous créez un fichier temporaire qui ne possède pas la feuille Notice et que les formules de mises en forme conditionnelle deviennent :
=A1=RECHERCHEV(A1;[Exemple.xlsm]Notice!#REF!;1;FAUX)

Avant de faire la copie sur le classeur temp, copier le tableau dans une feuille du même classeur et fusionner les formats et displayFormats par la macro suivante.

ou appliquer cette fusion directement sur la feuille avant d'en copier le tableau si vous n'avez plus besoin des MFC.

Code:
Sub CopierFormatConditionnel()
    Dim plg As Range, a As Range, c As Range
    On Error Resume Next
    Set plg = ActiveSheet.UsedRange.SpecialCells(xlCellTypeAllFormatConditions)
    On Error GoTo 0
    If Not plg Is Nothing Then
        For Each a In plg.Areas
            For Each c In a.Cells
                c.Interior.Color = c.DisplayFormat.Interior.Color
                c.Font.Color = c.DisplayFormat.Font.Color
                c.Font.Bold = c.DisplayFormat.Font.Bold
            Next
        Next a
        'Suppression des MFC
        plg.FormatConditions.Delete
    End If
End Sub
Cordialement
 

job75

XLDnaute Barbatruc
C'est vraiment se moquer du monde ! Le post #1 a été effacé et le fil est donc incompréhensible.

Si l'auteur a un minimum de savoir-vivre il doit rétablir le post #1 avec la question posée.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas