#VALUE! avec combinaison de SOMMEPROD, DECALLER et LIGNE

WISEDOME

XLDnaute Junior
Chers expert, je flash sur la formule ci-dessous depuis deux jours et ce malgré mes nombreuses recherches. Je me résigne donc à solliciter votre aide. La formule est la suivante:

=SUMPRODUCT((OFFSET(B$2;;;ROW(B2)-ROW(B$1);1)="Cuve Usine Pompe I")+(OFFSET(B$2;;;ROW(B2)-ROW(B$1);1)="Cuve Usine Pompe II")*(OFFSET(C$2;;;ROW(C2)-ROW(C$1);1)))

elle est sensée faire la somme de toutes les quantités de carburant sorties respectant les conditions suivantes:

- Modes de sorties = "Cuve Usine Pompe I" OU "Cuve Usine Pompe II"
- Plages à additionner: cellules en colonne C comprises entre C2 et Cx (x étant variable et correspondant au numéro de ligne de chaque cellule affichant le résultat du calcul.

J'ai joint un fichier excel pour faciliter la compréhension.

Vous remerciant d'avance pour votre sollicitude.


P.S: j'utilise Excel 2010.

______
Wisedome
 

Fichiers joints

vgendron

XLDnaute Barbatruc
Re : #VALUE! avec combinaison de SOMMEPROD, DECALLER et LIGNE

Hello

en D2=SOMMEPROD((($B$2:B2="Cuve Usine Pompe I")+($B$2:B2="Cuve Usine Pompe II"))*($C$2:C2))
et tu tires vers le bas
 

WISEDOME

XLDnaute Junior
Re : #VALUE! avec combinaison de SOMMEPROD, DECALLER et LIGNE

Hello vgendron,

Ca marche super bien! Mais je voudrais savoir pourquoi ma formule ne marche pas. Pourriez-vous m'aider à déceler ou se trouve l'erreur?

Merci encore pour la formule.

Cheers

Wisedome
 

vgendron

XLDnaute Barbatruc
Re : #VALUE! avec combinaison de SOMMEPROD, DECALLER et LIGNE

Bonne question...
apparemment.. le Decaler ne lui plait pas...
 

JHA

XLDnaute Barbatruc
Re : #VALUE! avec combinaison de SOMMEPROD, DECALLER et LIGNE

Bonjour à tous,

Ta formule ne donne pas le bon résultat mais si tu mets les parenthèses entre l'addition et que tu fais la somme et non sommeprod() car pas de matrice dans ta formule.
Code:
=SOMME(((DECALER(B$2;;;LIGNE(B2)-LIGNE(B$1);1)="Cuve Usine Pompe I")+(DECALER(B$2;;;LIGNE(B2)-LIGNE(B$1);1)="Cuve Usine Pompe II"))*(DECALER(C$2;;;LIGNE(C2)-LIGNE(C$1);1)))
JHA
 

WISEDOME

XLDnaute Junior
Re : #VALUE! avec combinaison de SOMMEPROD, DECALLER et LIGNE

Merci à JHA pour cette clarification. Merci encore pour ces deux formules qui resolvent mon problème!!

PROBLEME RESOLU!!!!
_________
Wisedome...
 

Discussions similaires


Haut Bas