#Valeur!

  • Auteur de la discussion pierrot
  • Date de début
P

pierrot

Guest
Bonjour à tous

Quelqu'un peut il m'expliquer pourquoi sur la formule du haut (classeur joint) ça me renvoie a #valeur!

Merci à tous


[file name=Classeur1_20060320163337.zip size=2200]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Classeur1_20060320163337.zip[/file]
 

Fichiers joints

Tibo

XLDnaute Barbatruc
Salut Pierrot,

Tu ne dois pas utiliser les guillemets quand tu fais appel à un nom.

Supprimes-les et tout rentre dans l'ordre

@+
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour Pierrot,

dans ta formule :

=SI($B8='';0;SI($B8<='HRM';($C8-$B8)-'TRM';$C8-$B8))+SI($D8='';0;SI($D8<='HRS';($E8-$D8)-'TRS';$E8-$D8))

HRM, TRM, HRS, TRS font réféernce a des cellules nommées donc il ne faut pas mettre ' ni devant ni derriere autrement il considere les lettre comme etant du texte donc ecrire simplement :

=SI($B8='';0;SI($B8<=HRM;($C8-$B8)-TRM;$C8-$B8))+SI($D8='';0;SI($D8<=HRS;($E8-$D8)-TRS;$E8-$D8))

Jocelyn

oup's bonjour Tibo désolé pour la colision et dans l'élan bonjour JJ59 :):)

Message édité par: Jocelyn, à: 20/03/2006 16:43
 
J

JJ59

Guest
Bonjour Pierrot, le Forum

voici la formule corrigée

'=SI($B8='';0;SI($B8<=HRM;($C8-$B8)-TRM;$C8-$B8))+SI($D8='';0;SI($D8<=HRS;($E8-$D8)-TRS;$E8-$D8))



Il faut enlever les '' aux HRM TRM etc...
Ceux sont les noms des cellulles.

Bon après-midi à tous

JJ59
 

pat1545.

XLDnaute Accro
Salut,

à première vue tu n'est pas en numérique , tu veux enlever des 'HRS' à des heures ...
Rien compris à ce que tu veux!
En recopiant celle du bas et en fixant les cellules:
=SI($B8='';0;SI($B8<=$B$1;($C8-$B8)-$B$2;$C8-$B8))+SI($D8='';0;SI($D8<=$B$3;($E8-$D8)-$B$4;$E8-$D8))

Bye
 

Discussions similaires


Haut Bas