#Valeur!

laeti95

XLDnaute Occasionnel
Bonjour le forum,

j'ai une formule qui indique #Valeur!

format de cellule = 00.00

Formule que j'aimerais changer :

=SI(F29="";0);SI(F29>12;"";ENT((MOD(AD29-F29;1))*24)+ARRONDI.INF(MINUTE(MOD(AD29-F29;1))/3;0)/20)

Un immense merci déjà d'avance à vos réponses.

Laeti
 

CHALET53

XLDnaute Barbatruc
Re : #Valeur!

Bonjour,

Et comme cela :

=SI(F29="";0;SI(F29>12;"";ENT((MOD(AD29-F29;1))*24)+ARRONDI.INF(MINUTE(MOD(AD29-F29;1))/3;0)/20))

a+
 

laeti95

XLDnaute Occasionnel
Re : #Valeur!

Bonjour Chalet53 et le forum,

Merci MERCI BEAUCOUP extra je suis contente, cela fonctionne...

Comment dois-je faire pour mieux apprendre les parenthèses ? Il y a un truc ou comment ?

MERCI Beaucoup

Laeti
 

CHALET53

XLDnaute Barbatruc
Re : #Valeur!

Re,

Il n'y a pas de techniques particulières : une parenthèse ouvrante doit trouver sa parenthèse fermante
dans ta formule : =SI(F29="";0);SI(F29>12;""; etc
après ton premier test : si(F29="";0 il ne faut pas fermer ta parenthèse à ce moment
Exemple dans une formule plus simple : si(F29="";0;1) signifie que si F29="" la valeur à mettre dans la cellule est 0 sinon 1(tu ne fermes pas la parenthèse après le 0
dans ton exemple, on remplace le 1 par une autre condition donc derrière le ";" qui suit 0 mettre directement : si(F29>12;""

C'est surtout une question de logique d'enchainement des conditions

a+
 

laeti95

XLDnaute Occasionnel
Re : #Valeur!

Bonsoir Chalet,

oui merci pour tes explications, je vais essayer de faire mieux la prochaine fois et de faire comme tu dis...

Encore MERCI

A+ et bonne soirée.

Laeti
 

Discussions similaires


Haut Bas