#valeur

FINPIER

XLDnaute Nouveau
bonsoir a tous,
je reviens vers vous car je suis entrain de faire un planning et je me retrouve confronté a un probleme.
a la fin de mon planning j'ai un decompte d'heure hebdomadaire qui calcul sans souci. Mais, he oui il y a un mais! dés que je met dans mon planning les jours de repos en texte bien sur le calcul hebdomadaire se transforme en #valeur.
si vous pouvez m'indiquer la formule pour que je puisse mettre du texte et calculer seulement les heures.
merci d'avance a vous tous
 

jeanpierre

XLDnaute Barbatruc
Re : #valeur

Bonsoir FINPÏER,

Sans en savoir plus...

Si tu utilises la fonction SOMME(), tu ne dois pas rencontrer ce problème. Tu dois donc faire un série de + et, là, ça ne passe pas.

Bonne soirée.

Jean-Pierre
 

ROGER2327

XLDnaute Barbatruc
Re : #valeur

Bonsoir FINPIER
Pour répondre, il faudrait au moins qu'on sût comment se présentent vos données et quelle genre de formule vous employez. Vous est-il possible de déposer un classeur avec des exemples de données et de formules qui posent des problèmes ?​
ROGER2327
#2132
 

FINPIER

XLDnaute Nouveau
Re : #valeur

rebonsoir a tous,
je vous envoie mon fichier a votre demande pour que vous puissiez vous rendre compte.
je suis d'accord avec toi pour la formule si les jours de repos ne change pas mais tous les quinze jour cela change et si je peut eviter de retaper les formules cela m'arange
merci encore pour votre aide
 

Fichiers joints

ROGER2327

XLDnaute Barbatruc
Re : #valeur

Re...
C'est plus facile en voyant le classeur !
Essayez
Code:
[COLOR="DarkSlateGray"][B]=SOMME(SI(ESTNUM($B3:$O3);SI(ESTNUM($B5:$O5);$B5:$O5-$B3:$O3;0);0))/2[/B][/COLOR]
(formule matricielle à valider par Ctrl + Maj + Entrée) en Q4 et
Code:
[COLOR="DarkSlateGray"][B]=Q4[/B][/COLOR]
en P3.
Je propose cette solution car il n'est pas possible de mettre la première formule en P3 à cause des cellules fusionnées.​
ROGER2327
#2134
 

FINPIER

XLDnaute Nouveau
Re : #valeur

la formule que tu me soumet me donne 00:00:00
je n'arrive pas a trouver la solution
merci de ton soutien
 

FINPIER

XLDnaute Nouveau
Re : #valeur

ROGER2327
je dois te dire merci
effectivement je n'ai jamais mis en doute tes capacité mais la confiance que j'ai en moi a ce sujet et toute relative .
encore merci et a bientôt
 

jeanpierre

XLDnaute Barbatruc
Re : #valeur

Bonjour FINPIER, ROGER2327,

On peut aussi écrire en P3 fusionné :
=SI(ESTERREUR((SOMME(B5:O5)-SOMME(B3:O3)))/2=FAUX;"";((SOMME(B5:O5)-SOMME(B3:O3))/2))

A saisir directement mais non par le Copier/Coller pour P3 uniquement, ensuite le copier/coller classique vers les autres cellules.

Un peu plus long seulement.

Bonne journée.

Jean-Pierre
 
Dernière édition:

ROGER2327

XLDnaute Barbatruc
Re : #valeur

Re...
Bonjour FINPIER, ROGER2327,

On peut aussi écrire en P3 fusionné :
=SI(ESTERREUR((SOMME(B5:O5)-SOMME(B3:O3)))/2=FAUX;"";((SOMME(B5:O5)-SOMME(B3:O3))/2))

A saisir directement mais non par le Copier/Coller pour P3 uniquement, ensuite le copier/coller classique vers les autres cellules.

Un peu plus long seulement.

Bonne journée.

Jean-Pierre
Cela évite effectivement l'utilisation d'une cellule auxiliaire. Mais les deux formules ne font pas exactement la même chose en cas de remplissage partiel de la grille. Selon l'usage que l'on a du tableau, ce n'est peut-être pas un problème, mais il vaut mieux le savoir.​
Cordialement,
ROGER2327
#2138
 

Fichiers joints

Discussions similaires


Haut Bas