XL 2016 #Valeur! sur formule soustraction et autres.

Fipat

XLDnaute Nouveau
Bonjour,

vous avez surement déjà eu une multitude de fois cette question. Mais je viens vous solliciter car malgré tout les tests que j'ai pu faire une seule fonctionne.
Mais vue que ma base de donnée fait plusieurs milliers de lignes, je voudrais trouver une solution plus efficace.

Je fais une extraction depuis un programme et celui-ci me donne ma base.
Le souci est que pour avoir le résultat du calcul je suis obligé de retaper les chiffres de la base un par un.

J'ai vérifier le calcul automatique, j'ai essayer de convertir en Standard, en nombre, en texte, personnalisé..., j'ai également essayer de convertir (sous données), mais idem.

Voici un exemple :
Feuil1 la base de données extraites du programme.
Feuil2 la recherche (même si eclle-ci n'est pas importante pour ma requête, mais ça donne un exemple de ce que je veux faire).

Si vous avez une idée, merci d'avance.
 

Fichiers joints

Fipat

XLDnaute Nouveau
Merci pour votre réactivité !
Voici ce que j'ai, j'ai essayé de remplacer cette série sous "Rechercher"

à la base j'ai ceci :

2019-09-24_195648.gif

Remplacé par un point.

2019-09-24_200443.gif

Quand j'ai fait cette manipulation je suis obligé de valider cellule par cellule (bouton remplacer).
Étant donné que mon fichier base doit contenir ± 100 000 cellules, difficile de valider manuellement.
Mais votre solution fonctionne, mais difficilement applicable pour des dizaines de milliers de cellules.

Merci pour votre retour.
 

Fipat

XLDnaute Nouveau
Désolé, votre solution est nickel avec remplacer tout !!!
trop vite.

Merci beaucoup Gardien de phare.
Ca marche nickel avec ma base ;)
 

Fipat

XLDnaute Nouveau
Bon désolé !
Cela fonctionne sur mon fichier base de travail.
Mais mon
VB:
=SIERREUR(RECHERCHEV(A30;Feuil13!$A:$T;19;0);"")
ne fonctionne pas sur mon fichier de travail.
Alors que sur le fichier exemple de ce sujet ça marche nickel.

J'ai une grosse base de données et je travaille sur plusieurs tableaux dynamiques sur une feuille la requête
VB:
=SIERREUR(RECHERCHEV(A30;Feuil13!$A:$T;19;0);"")
se fait sur cette feuille de tableaux dynamiques.

Tout comme le fichier exemple je devrait retrouver cette requête.

Bon je creuse ! En tout merci car cette étape de calcul de soustraction qui est franchie ;)
 

Gardien de phare

XLDnaute Accro
Re,
Il faut bien sûr, intervenir sur la BDD en amont du TCD. Il faut aussi chercher du coté de la création de la BDD. Perso, j'utilise dans Excel des BDD issues d'un logiciel US, donc avec le point comme séparateur décimal, mais je sais comment exporter mes bases avec un séparateur décimal virgule puisque mon Excel est européanisé.
 

Fipat

XLDnaute Nouveau
Bonsoir,
Oui merci pour ce point de sensibilisation.
La BDD doit être au point avant le TCD, encore une fois trop vite..
Pour le reste Euro; US, ça me dépasse :oops:
En tout cas, vraiment un grand Merci. Cette erreur de la base est réglée.

Il me reste plus qu'a comprendre pourquoi cette "RECHERCHEV" ne fonctionne pas.
Peut-être ajouter un filtre ("*"$"*") ?
 

Gardien de phare

XLDnaute Accro
Re,
Pour le RECHERCHEV , je ne vois pas... En revanche, il y aurait tout intérêt à utiliser des tableaux structurés avec la syntaxe des tableaux ce qui évite le SIERREUR et la recherche sur des colonnes entières, procédé plutôt déconseillé.
Voir le classeur joint
 

Fichiers joints

Haut Bas