Utiliser les Fonctions SI et DATE dans Excel 2010

benabou

XLDnaute Nouveau
Bonjour,

Dans le fichier, en pièce-jointe, en utilisant la fonction SI de Excel 2010 et dans une 3ième colonne, je veux que les dates inférieures ou égale à 1984 deviendront 1992, celles comprises entre 1984 et 1990 seront élevées de 10 ans et en fin celles supérieures strictement à 1990 resteront inchangées.
tout celà, sans toucher au mois ni au jour.

Merci infiniment.
 

Fichiers joints

mapomme

XLDnaute Barbatruc
Supporter XLD
Re : Utiliser les Fonctions SI et DATE dans Excel 2010

Bonjour benabou et bienvenue sur XLD :)

un essai avec la formule:
Code:
=SI(ANNEE(B2)<=1984;DATE(1992;MOIS(B2);JOUR(B2));SI(ANNEE(B2)<=1990;DATE(ANNEE(B2)+10;MOIS(B2);JOUR(B2));B2))
 

Fichiers joints

benabou

XLDnaute Nouveau
Re : Utiliser les Fonctions SI et DATE dans Excel 2010

Bonjour.

Je vous remercie infiniment.

Encore une fois Merci, pour votre partage, .
 

Discussions similaires


Haut Bas