Une formule SI et Produit avec réponse dans deux cellules ?

patrickvanec

XLDnaute Nouveau
Bonjour,

Je dois répondre par une formule SI imbriqué et avec produit, + un choix entre 2 colonnes selon le résultat (ici il s'agit d'un certains nombre d'action, il faut calculer si on est en perte ou gain (2 colonnes différentes E et F, une pour gain et une pour perte). De plus dans le portefeuille de 5 actions, le volume pour chacune des actions est différent. Désolé c'est quelque peu confus !

Ce sera beaucoup plus clair en ouvrant directement le classeur joint qui est en soi l'énoncé du problème. J'ai essayé toute une série de formules SI en y insérant "Produit", etc. sans résultat !

Merci de votre aide !
 

Fichiers joints

excfl

XLDnaute Accro
Re : Une formule SI et Produit avec réponse dans deux cellules ?

Bonsoir patrickvanec,

E3 : =SI(D3>C3;(D3-C3)*B3;"")

F3 : =SI(C3>D3;(C3-D3)*B3;"")

Formules à tirer vers le bas.

Vérification : =SOMMEPROD(D3:D8*B3:B8)-SOMMEPROD(C3:C8*B3:B8)

excfl
 
Dernière édition:

patrickvanec

XLDnaute Nouveau
Re : Une formule SI et Produit avec réponse dans deux cellules ?

Merci infiniment excfl
Je pensais bien qu'il fallait 2 formules différentes, j'ai ajouté un 0 (zéro) entre les guillemets, mais bizarrement ils ne s’alignent pas à droite (bizarre...) N'importe, MERCI ENCORE !
Patrick (patrickvanec)
 

excfl

XLDnaute Accro
Re : Une formule SI et Produit avec réponse dans deux cellules ?

Re,

Merci infiniment excfl
Je pensais bien qu'il fallait 2 formules différentes, j'ai ajouté un 0 (zéro) entre les guillemets, mais bizarrement ils ne s’alignent pas à droite (bizarre...) N'importe, MERCI ENCORE !
Patrick (patrickvanec)
J'ai remplacé les "" par O dans le fichier joint post 3 et ils s'alignent à droite comme tout chiffre ou nombre.

excfl
 
Dernière édition:

patrickvanec

XLDnaute Nouveau
Re : Une formule SI et Produit avec réponse dans deux cellules ?

Oui, évidemment ce n'est pas un texte, mais un chiffre. Merci encore !
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas