1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

Une astuce pour rendre vos formules complexes plus lisibles!

Discussion dans 'Trucs et astuces' démarrée par David XLD, 2 Juin 2017.

Par David XLD le 2 Juin 2017 à 12:48
  1. David XLD

    David XLD Administrator Membre de l'équipe

    Inscrit depuis le :
    4 Juin 2006
    Messages :
    2116
    "J'aime" reçus :
    271
    Sexe :
    Masculin
    Habite à:
    Lyon
    Utilise:
    Excel 2013 (PC)
    Formule.jpg
    Qui ne s'est pas déjà lancé dans des imbrications de formules SI avant de se perdre totalement dans leur logique?
    Il arrive parfois que l'on crée des formules complexes avec de nombreux arguments qui deviennent très difficile à lire et donc à maintenir.
    Il existe pourtant une façon simple de rendre ces formules beaucoup plus lisibles.
    Pour cela, il suffit d'insérer des sauts de lignes entre les différentes parties de vos formules.

    Par exemple, imaginons que vous ayez une formule de ce genre dans votre fichier:
    =SI(A1>16;"Excellent";SI(A1>12;"Bon";SI(A1>8;"Médiocre";SI(A1>4;"Faible";"Mauvais"))))

    Pour améliorer la lisibilité de la formule, insérez des sauts de ligne avant les fonctions SI et tout devient beaucoup plus clair.
    Pour insérer un saut de ligne, positionnez le curseur avant le SI, maintenez la touche ALT appuyée, puis appuyez sur la touche ENTER.
    Voici la même formule après insertion des sauts de ligne:

    =SI(A2>16;"Excellent";
    SI(A2>12;"Bon";
    SI(A2>8;"Médiocre";
    SI(A2>4;"Faible";"Mauvais"))))

    Beaucoup mieux, n'est ce pas? :)
     
    arthour973, Régis57, LouisLord et 3 d'autres aiment votre message.

Commentaires

Discussion dans 'Trucs et astuces' démarrée par David XLD, 2 Juin 2017.

Partager cette page