Résolu Trouver toutes les combinaisons possibles

Niko71

XLDnaute Nouveau
Bonjour à tous :)

Avant toute chose un grand merci aux personnes qui font vivre ce forum en apportant quotidiennement leur aide. J'en ai déjà profité un bon paquet de fois!

Mais aujourd'hui je ne trouve pas de réponse à mon problème. Je souhaite trouver toutes les combinaisons possibles d'éléments appartenant à plusieurs colonnes. J'ai trouvé cette formule sur votre forum qui me permet, en les combinant à chaque fois deux par deux, de trouver ce que je cherche:

Code:
=SI(NBVAL($A$1:$A$30)*NBVAL($B$1:$B$30)<LIGNE(1:1);"";
DECALER(A$1;ENT((LIGNE(1:1)-1)/(NBVAL($B$1:$B$30)));)&" - "&
DECALER(B$1;MOD(LIGNE(1:1)-1;NBVAL($B$1:$B$30));))

Le problème, c'est que j'obtiens toutes les combinaisons dans une seule colonne, hors, j'aimerai que chaque élément de ma combinaison apparaisse sur une même ligne, mais dans des cellules différentes.
Exemple, au lieu de:
C1: renault - Mégane - diesel
J'aimerai
C1: renault, C2: Mégane, C3: Diesel

Celà me permettrai de filtrer beaucoup plus facilement par la suite à travers un tableau pour enlever rapidement les combinaisons impossibles.

J'espère être assez clair.
Merci :)
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Re,
Sinon :
1° colonne :
VB:
=SI(NBVAL($A$1:$A$30)*NBVAL($B$1:$B$30)<LIGNE(1:1);"";DECALER(A$1;ENT((LIGNE(1:1)-1)/(NBVAL($B$1:$B$30)));))
2° colonne :
Code:
=SI(NBVAL($A$1:$A$30)*NBVAL($B$1:$B$30)<LIGNE(1:1);"";DECALER(B$1;MOD(LIGNE(1:1)-1;NBVAL($B$1:$B$30));))
 

Niko71

XLDnaute Nouveau
Merci Victor21, pour cette réponse rapide!
J'essaie ça dès que j'ai un peu de temps :)
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas