Trouver le numéro de la ligne

denisbouchard

XLDnaute Junior
Bonjour à tous,
Je dois faire un calcul avec le numéro de la ligne de la cellule, par exemple :
si je place "X" dans la cellule "A24", je voudrais faire 24 - 3. Quelqu'un a-t-il une macro qui puisse trouver le numéro de la ligne dans laquelle je mets "x" ?
Merci pour vos futures réponses.
Denis
 

Fred0o

XLDnaute Barbatruc
Re : Trouver le numéro de la ligne

Bonjour denis,

Pas besoin de macro, la fonction suivante te permet de répondre à ton besoin :
Code:
=LIGNE()-3
A+
 

poulie

XLDnaute Impliqué
Re : Trouver le numéro de la ligne

Bonjour denisbouchard, Fred0o, bonjour à tous,

Peut-être cette formule, si j'ai bien compris. La plage est à adapter.

=SI(ESTERREUR(EQUIV("x";$A$1:$A$20;0)-3);"";EQUIV("x";$A$1:$A$20;0)-3)

Bonne réception
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas