Trouver et valider des données sur deux fichiers distincts

fafardel

XLDnaute Nouveau
Bonjour à tous

J'ai deux fichiers excel avec des données de type numéro de série et nom de poste de travail.
J'ai un autre fichier avec numéro de série et nom de poste de travail.
Ces deux fichiers provenant d'extraction de deux programmes différents, je voudrai vérifier que les données d'un fichier sont bien dans l'autre fichier sans bien sur faire un copier coller
En fait une recherche dans un des fichiers dois me dire si les valeurs sont dans l'autre

Je vous joins un exemple des deux fichiers

Merci de votre aide
 

Fichiers joints

Dernière édition:

JNP

XLDnaute Barbatruc
Re : Trouver et valider des données sur deux fichiers distincts

Bonjour Farfadel :),
Il y aurait des données communes entre tes fichiers que ce serait mieux pour tester :mad:...
En C2 du fichier 1 à glisser vers le bas
Code:
=SI(NB.SI('[fichier 1.xls]Feuil1'!$C:$C;B2)>0;"Oui";"Non")
Bonne journée :cool:
 

fafardel

XLDnaute Nouveau
Re : Trouver et valider des données sur deux fichiers distincts

J'ai modifié les fichiers de sorte qu'ils contiennent des données similaires
J'ai essayé ta formule et ça fonctionne pas
Désolé
 

JNP

XLDnaute Barbatruc
Re : Trouver et valider des données sur deux fichiers distincts

Re :),
J'ai essayé ta formule et ça fonctionne pas
Quand je l'ai testé sur ton fichier, le calcul automatique était désactivé, mais en appuyant F9 (après avoir copié/collé certaines valeurs pour en avoir des similaires), ça fonctionnait :rolleyes:...
A moins que 2003 ne supporte pas les colonnes entières en NB.SI (il me semblait pourtant que oui :p), à ce moment-là, tu peux tester
Code:
=SI(NB.SI('[fichier 1.xls]Feuil1'!$C$2:$C$35000;B2)>0;"Oui";"Non")
Bon courage :cool:
 

fafardel

XLDnaute Nouveau
Re : Trouver et valider des données sur deux fichiers distincts

JNP
Merci de ton aide
MAis la formule ne marche pas mais je crois avoir compris ta démarche
Je pense que je me suis mal expliqué
En fait je voudrai que dans la colonne C du fichier SN-FRANCE.XLS
LA formule aille rechercher dans le fichier fichier 1.xls si le numéro de série existe et s'il existe me mette un mot du type ok ou autre pour faire une concordance
Je suis dsolé pour cette méprise et encore merci du temps que tu me consacres
 

JNP

XLDnaute Barbatruc
Re : Trouver et valider des données sur deux fichiers distincts

Re :),
MAis la formule ne marche pas mais je crois avoir compris ta démarche
Tant mieux si tu as compris la démarche, car je ne vois pas ce que je peux faire de plus :eek:...
=SI(condition;"Oui";"Non")
fait le test.
NB.SI('[Nom du fichier OUVERT]Nom de l'onglet'!$Colonne$Première ligne:$Colonne$Dernière Ligne;Cellule à tester)>0
compte si la valeur est au moins présente une fois dans la colonne.
Bon courage :cool:

 

fafardel

XLDnaute Nouveau
Re : Trouver et valider des données sur deux fichiers distincts

Re :),Tant mieux si tu as compris la démarche, car je ne vois pas ce que je peux faire de plus :eek:...
=SI(condition;"Oui";"Non")
fait le test.
NB.SI('[Nom du fichier OUVERT]Nom de l'onglet'!$Colonne$Première ligne:$Colonne$Dernière Ligne;Cellule à tester)>0
compte si la valeur est au moins présente une fois dans la colonne.
Bon courage :cool:

Merci beaucoup ça fonctionne nickel
Encore un grand merci
 

Discussions similaires


Haut Bas