Résolu Trier les données d'une ligne et ajouter le résultat dans une nouvelle colonne

stagiaire1

XLDnaute Nouveau
Bonjour,

J'aimerais pouvoir isoler des données d'une ligne dans une même colonne.
En colonne, il y a 7 différentes Formations et dates (jj/mm/aaaa) à laquelle elle a été effectué.
En ligne, les noms et prénoms.

Je voudrais donc, dans une colonne à part, avoir uniquement l'année 2019 de la ligne (sachant que les jours et mois ne sont pas les mêmes) et donc trier l'ensemble des dates par rapport à la ligne.
Les formations ne commencent pas à la même date. L'année 2019 peut alors être dans des formations différentes (et non toute dans la même colonne, je ne peux pas utiliser un filtre).


J'ai essayé avec RECHERCHEV mais cela ne fonctionne pas.

Merci pour votre aide!
 

dg62

XLDnaute Accro
bonjour Stagiaire1

ta demande est assez confuse, un exemple avec état initial et résultat attendu dans un petit fichier excel pourrait peut-être accélérer la résolution de ton problème.
 

stagiaire1

XLDnaute Nouveau
Ci-joint le fichier excel.
J'aimerais que dans la colonne K se trouve la date de l'année 2019 de chaque ligne.
Par exemple, en K2, avoir H2. Je ne peux pas le faire manuellement car beaucoup trop de données dans le tableau d'origine.
Il faudrait donc que excel arrive à trier la ligne 2 et choisisse H2 car date 2019 et qu'il la mette en K2
Est-ce plus clair?

Merci beaucoup pour votre aide!
 

Fichiers joints

stagiaire1

XLDnaute Nouveau
Par exemple, pour K2, il faudrait une formule comme
=SI(ANNEE(D2)=ANNE(AUJOURDHUI());D2;"");(ANNEE(E2)=ANNEE(AUJOURDHUI();E2;"");ANNEE(F2)=ANNEE(AUJOURDHUI());F2;"");ANNEE(G2)=AUJOURDHUI();G2;"");ANNEE(I2)=ANNEE(AUJOURDHUI);I2;"");ANNEE(J2)=ANNEE(AUJOURDHUI();J2;"")

....
 

Efgé

XLDnaute Barbatruc
Bonjour à tous

S'il ne peut y avoir qu'une date par année dans chaque ligne:
En K2 et à tirer vers le bas:
VB:
=SOMMEPROD((ANNEE(D2:J2)=ANNEE(AUJOURDHUI()))*D2:J2)
Cordialement
 

stagiaire1

XLDnaute Nouveau
Bonjour à tous

S'il ne peut y avoir qu'une date par année dans chaque ligne:
En K2 et à tirer vers le bas:
VB:
=SOMMEPROD((ANNEE(D2:J2)=ANNEE(AUJOURDHUI()))*D2:J2)
Cordialement
Merci cela fonctionne!!

Dernière petite question... si il n'y a rien dans les lignes, que puis-je ajouter à cette formule, disant qu'il ne faut rien faire??
Merci!
 

Efgé

XLDnaute Barbatruc
Re

Je m'étais trompé, désolé.
Je t'ai fait un fichier exemple.
Il est inutile de tirer la formule plus bas que nécessaire.
En utilisant un tableau (Onglet Accueil / Mettre sous forme de tableau) tu n'as qu'a rentrer le nom de la personne et la date de sa première formation. Toutes les formules des colonnes suivantes seront mises à jour.

Fait le test dans mon exemple.

Cordialement
 

Fichiers joints

stagiaire1

XLDnaute Nouveau
Merci beaucoup, vous êtes d'une grande aide!
Par contre, si il y a des dates présentes dans la ligne, mais autre que 2019, cela m'affiche 00/01/1900, est-ce un problème de paramètre de mon excel?
 

Efgé

XLDnaute Barbatruc
Re
Non.
S'il n'y a pas de date correspondent à l'année en cours, la formule renvoie 0.
Il faut savoir que pour excel 0 = 00/01/1900.
Donc on peux aller au plus simple :
Sélectionne ta colonne Année en cours / Clic droit / format de cellule / Format personnalisé / jj/mm/aaaa;;"-"

Voir le fichier joint.
Cordialement
 

Fichiers joints

Discussions similaires


Haut Bas