XL 2016 Transformer une formule texte en vraie formule

SMEAGOAL

XLDnaute Junior
Bonjour,
Je m'explique:
A B C
1 5
2 6
3 =1+2 11

J'écris en B3 la formule: ="="&A1&"+"&A2, ce qui donne "=1+2"
J'aimerais que C3 recherche les cases C1 et C2 et les additionne en se référant à la cellule B3,
Est-ce possible?
Merci.
 
Solution
Il fallait ajouter un astérisque * devant le 1er HC de la formule matricielle.

Voyez le fichier joint et cette formule matricielle (simplifiée) en G12 :
Code:
=SI(SOMME(-ESTNUM(CHERCHE("+"&$A$6:$A11&"+*HC";SUBSTITUE($B12;"=";"+")&"+"&G$6:G11)));"HC";SOMME(SI(ESTNUM(TROUVE("+"&$A$6:$A11&"+";SUBSTITUE($B12;"=";"+")&"+"));G$6:G11)))
A+

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour SMEAGOAL, job75, JHA, Etoto,

J'arrive bien après la bataille mais pour le Fun une formule bien plas courte sans validation matricielleet qui fonctionne sans limite de 3 ou 4 ou 5 données dans le =1+2+3.... du moins je crois

VB:
=SOMMEPROD((ESTNUM(CHERCHE("+"&$A$2:$A$7;SUBSTITUE(B7;"=";"+"))))*$C$2:$C$7)

Cordialement

EDIT : Bonjour a Yeahou aussi que je n'avais pas vu
 
Dernière édition:

SMEAGOAL

XLDnaute Junior
Bonjour le Forum,
Bonjour SMEAGOAL, job75, JHA, Etoto,

J'arrive bien après la bataille mais pour le Fun une formule bien plas courte sans validation matricielleet qui fonctionne sans limite de 3 ou 4 ou 5 données dans le =1+2+3.... du moins je crois

VB:
=SOMMEPROD((ESTNUM(CHERCHE("+"&$A$2:$A$7;SUBSTITUE(B7;"=";"+"))))*$C$2:$C$7)

Cordialement
Merci Jocelyn,
Je ne vois pas la raison du sommeprod? Il n' y a qu'une seule matrice dans la formule et en plus je ne dois faire que des sommes... Ou alors j'ai pas bien compris?
 

Jocelyn

XLDnaute Barbatruc
re

sur la base du fichier a Job je te mets le fichier avec ma formule en colonne

le sommeprod dans sa partie estnum marque d'un 1 toutes les lignes ou la valeur est numérique et multiplie 1 par la valeur de la colonne C et en fait l'addition

Cordialement
 

Pièces jointes

  • Transformer une formule(1)-1.xlsx
    15.9 KB · Affichages: 10

job75

XLDnaute Barbatruc
Bonjour Jocelyn,

Ah mais oui ta formule est beaucoup plus simple.

Mais il faut la corriger car elle ne donne pas le bon résultat en F12 de ce fichier (2).

Formule corrigée en G4 à recopier plus bas :
Code:
=SOMMEPROD(ESTNUM(TROUVE("+"&$A$2:$A$12&"+";SUBSTITUE(B4;"=";"+")&"+"))*$C$2:$C$12)
A+
 

Pièces jointes

  • Transformer une formule(2).xlsx
    10.9 KB · Affichages: 6

SMEAGOAL

XLDnaute Junior
Ca marche!!!
Simple et efficace! Merci beaucoup!!
Bonjour Jocelyn,

Ah mais oui ta formule est beaucoup plus simple.

Mais il faut la corriger car elle ne donne pas le bon résultat en F12 de ce fichier (2).

Formule corrigée en G4 à recopier plus bas :
Code:
=SOMMEPROD(ESTNUM(TROUVE("+"&$A$2:$A$12&"+";SUBSTITUE(B4;"=";"+")&"+"))*$C$2:$C$12)
A+
Incroyable, j'étais sur le point de soulever ce problème!
Comment faites-vous??
Merci!
 

Pièces jointes

  • Transformer une formule sans formule matricielle joc.xlsm
    10.9 KB · Affichages: 2

SMEAGOAL

XLDnaute Junior
Bonjour,
Je voudrais savoir si il est possible, lorsque le résultat d'un produit trouve un zéro, le sommeprod renvoie zéro au lieu de faire la somme des résultats différents de zéro,
Ce n'est pas très clair, voir mon fichier joint avec le commentaire sur la cellule g12.
Merci encore.
 

Pièces jointes

  • Transformer une formule sans formule matricielle joc.xlsm
    10.7 KB · Affichages: 7

Jocelyn

XLDnaute Barbatruc
Re,

Bon a priori pour ta demande rien à changer dans la formule juste a ce qu'elle soit présente dans toute les cellule de G ou alors je n'ai toujours pas compris

Cordialement
 

Pièces jointes

  • Transformer une formule sans formule matricielle joc.xlsm
    16.1 KB · Affichages: 2

SMEAGOAL

XLDnaute Junior
Re,

Bon a priori pour ta demande rien à changer dans la formule juste a ce qu'elle soit présente dans toute les cellule de G ou alors je n'ai toujours pas compris

Cordialement
Re,
Je suis désolé je me suis trompé de fichier!
Ca devrait être plus clair maintenant?
 

Pièces jointes

  • Transformer une formule sans formule matricielle modif.xlsm
    13.5 KB · Affichages: 3

Jocelyn

XLDnaute Barbatruc
re,

C'est pas facile tous les jours, ;)

Suivant ton nouveau fichier et avec les valeurs indiquées tu voudrais quel résultat et ou

si dans ton exemple tous les résultat sont bon refait un exemple avec des données qui te donnent un résultat que tu voudrais changer

car la à la vue des donnée aucune des cellules contenant le sommeprod ne doit donner 0

Ou une fois de plus je n'ai pas compris ce qui est de l'ordre du possible

Cordialement
 

SMEAGOAL

XLDnaute Junior
re,

C'est pas facile tous les jours, ;)

Suivant ton nouveau fichier et avec les valeurs indiquées tu voudrais quel résultat et ou

si dans ton exemple tous les résultat sont bon refait un exemple avec des données qui te donnent un résultat que tu voudrais changer

car la à la vue des donnée aucune des cellules contenant le sommeprod ne doit donner 0

Ou une fois de plus je n'ai pas compris ce qui est de l'ordre du possible

Cordialement
Au départ je n'avais pas un 0 dans G10 mais "HC",
Du coup la formule ne fonctionne plus car ce n'est plus un nombre,
J'ai donc remplacé le "HC" par un 0 pour que la formule fonctionne mais ça fausse mes résultats car il faudrait que G12 soit égal à 0 et pas à 1,5!
Je peux bien sûr rentrer un 0 manuellement mais c'est source d'erreur car je copie/colle la ligne et ne vois pas qu'il n'y a plus de formule.
Plus clair ou pas du tout?
 

Pièces jointes

  • Transformer une formule sans formule matricielle modif.xlsm
    13.7 KB · Affichages: 2

Discussions similaires

Statistiques des forums

Discussions
292 811
Messages
1 926 467
Membres
183 093
dernier inscrit
Juvenat