XL 2013 Transférer et cumuler des données dans des cellules cibles

davy76

XLDnaute Nouveau
Bonjour,

je fais appel a vous, je dispose de 2 fichiers, le 1er appeler référence contient des données par voies et numéro de voies et dans le 2eme fichier comptage test les voies sont regroupées. Ce que j'aimerais c'est que les données de la colonne E du fichier référence se copient dans les cases correspondante du fichier comptage en colonne F. Par exemple, que les données colonne E de la voie "AIDLING" se copient et se cumulent ligne 40 en cellule F du fichier comptage et ainsi de suite.

Merci de votre aide
 

Fichiers joints

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Davy,
Un essai en PJ avec :
VB:
=SOMME.SI.ENS([reference.xlsx]Feuil1!$E$1:$E$50000;[reference.xlsx]Feuil1!$A$1:$A$50000;A5;[reference.xlsx]Feuil1!$D$1:$D$50000;"*"&GAUCHE($B5;TROUVE("(";$B5)-2)&"*")
A noter que les deux fichiers doivent être impérativement ouverts.
( L'extension de la Pj est en xlsb pour passer sous la barre des 1Mo fatidiques. Pour l'utilisateur c'est la même chose qu'un xlsx sous Windows, mais pose problème sous Android ou IOS, il suffit de l'enregistrer de nouveau en xlsx )
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour davy76, sylvanu,
A noter que les deux fichiers doivent être impérativement ouverts.
En effet avec SOMME.SI.ENS mais ce n'est pas le cas avec SOMMEPROD.

Téléchargez les 2 fichiers joints dans le même dossier (le bureau).

Dans le fichier Comptage test(1).xls j'ai supprimé 3 colonnes inutiles pour l'alléger.

A+
 

Fichiers joints

davy76

XLDnaute Nouveau
Bonjour a tous,

merci pour vos conseils, le seul hic c'est que si C4 est vide, il multiplie le résultat de A4 par 0. Donc j'ai 0 au total. Pour Anzeling par exemple, je ne devrais pas être a 0 mais a 10.8.
 

davy76

XLDnaute Nouveau
J'ai trouvé en cumulant une condition j'arrive a jongler entre un somme.si.ens et un somme prod.

=SI(C5="";SOMME.SI.ENS(Travail!$E$1:$E$13900;Travail!$A$1:$A$13900;A5);SOMMEPROD((Travail!$A$1:$A$13900=A5)*(Travail!$D$1:$D$13900=C5);Travail!$E$1:$E$13900))

Par contre lorsque j'ai un rue ou une impasse qui porte le même nom il ne fait pas la différence. Du coup, quand j'injecte 700 référence, il m'en trouve 737 au total dans mon tableau.
 

Fichiers joints

job75

XLDnaute Barbatruc
merci pour vos conseils, le seul hic c'est que si C4 est vide, il multiplie le résultat de A4 par 0. Donc j'ai 0 au total. Pour Anzeling par exemple, je ne devrais pas être a 0 mais a 10.8.
Ca c'est n'importe quoi, à part ANZELING la ligne 4 est vide, le résultat ne peut être que zéro.

Et mélanger SOMME.SI.ENS et SOMMEPROD je n'ose le qualifier.
 

davy76

XLDnaute Nouveau
il y a plusieurs commune qui n'ont pas d'information en colonne B et C, il faut bien aller rechercher les données de ces communes qui ne sont pas 0 dans l'onglet travail.
Pourquoi je ne pourrais pas associer les 2 fonctions, je ne comprends pas.
j'essai de trouver des solutions avec mes moyens. Comment ferais tu job75 ?
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas