Tester si une cellule contient une date

caritijak

XLDnaute Nouveau
Bonjour,

Tout est dans le titre, une série de cellule peut contenir soit du caractère (x, oui, non ...) soit une date. Pour chacune, je voudrais tester si elle contient une date ou pas.

Merci de votre aide.
Cordialement
 

Pierrot93

XLDnaute Barbatruc
Re : Tester si une cellule contient une date

Bonjour,

si tout est dans le titre alors, essaye ceci :
Code:
Dim c As Range
For Each c In Range("A1:A10")
    MsgBox IsDate(c)
Next c
bon après midi
@+
 

caritijak

XLDnaute Nouveau
Re : Tester si une cellule contient une date

Merci pour la rapidité de la réponse.

Effectivement tout n'était pas dans le titre : je cherche la formule à insérer dans une cellule et non dans une macro vb.

Cordialement.
 

caritijak

XLDnaute Nouveau
Re : Tester si une cellule contient une date

Bon, j'ai une trouvée une solution, peut-être pas très élégante mais qui me convient pour l'instant : je teste si la cellule contient un chiffre supérieur à 0

=SI(ET(ESTNUM(E6);E6>0);"Date";"Pas date")

Si ça peut servir à d'autres ...
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas