test sur date avec la fonction AUJOURD'HUI()

Y

yann

Guest
bonjour,

j'aurai aimé avoir un exemple ou la syntaxe afin de faire un test sur une date avec la fonction aujourd'hui

je vous explique:

Dans une cellule j'ai ma fonction aujourd'hui

La date renvoyé je veux traiter ce qui est renvoyé

c'est a dire que si la date est inférieur au 16 du mois elle me renvoie le premier du mois suivant et si la jour est supérieur elle me renvoie le premier du mois encore apres
ex 16 janvier 2004 ==> 1 MARS 2004

mon probleme c'est que si j'ai une date supérieur a 16 et que l'on arrive dans la fin de l'année par exemple Décembre je ne vois pas la syntaxe à mettre en place dans la cellule...

merci de votre aide

yannL
 
H

Hervé

Guest
Bonjour

premiere tentative de calcul sur des dates (Mansuétude SVP) de ma part :

ta date en A1

cette formule en B1 :

=SI(JOUR(A1)<16;FIN.MOIS(A1;-1)+1;FIN.MOIS(A1;1)+1)

salut
Hervé
 
Y

yann

Guest
je te remercie de ta réponse mais le probleme c'est que la formule me renvoi zéro est ce normal???

Cordialement,
yannL
 
H

Hervé

Guest
re

Non ce n'est pas normal tu as bien une date en A1 au format jj/mm/aa.

sinon pour essai, tente ceci :

=SI(JOUR(aujourdhui())<16;FIN.MOIS(aujourdhui();-1)+1;FIN.MOIS(aujourdhui();1)+1)

salut
Hervé
 
Y

yann

Guest
je te remercie du coup de main j'ai trouvé une autre solution que je posterai si toute fois ça peut aider quelqu'un sur le forum

Cordialement;
yannL
 

Discussions similaires


Haut Bas