Test sur colonne avec condition date

Temjeh

XLDnaute Accro
Bonjour et merci d'avance
J'ai ceci qui fonctionne pour extraire les montants de postes en colonne:

=SOMME.SI(I11:I591;"Poste:";J11:J591)

Sauf que j'aimerais y ajouté une condition mais ca me semble impossible, du moins avec ce somme.si.

Voici la condition:
J'ai aussi une date.
Somme que les données du trimestre?

Merci beaucoup pour votre temps

Claude
 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
Re : Test sur colonne avec condition date

Bonjour le Forum,
Bonjour Temjeh,

Un essai en fichier joint, j'ai mis une liste déroulante en G1 pour choisir le trimestre

Ciordialement

EDIT j'ajoute un fichier qui fonction avec une plage nommée dynamique que l'on décale selon le critère que l'on cherche
 

Fichiers joints

Dernière édition:

Temjeh

XLDnaute Accro
Re : Test sur colonne avec condition date

Wow

Merci beaucoup

La perfection:

=SOMMEPROD((I7:I38="Poste:")*(MOIS(C4:C35)<=G1*3)*(MOIS(C4:C35)>(G1-1)*3)*J7:J38)

J'ai juste de la difficulter à le mettre dans ma feuille maitre.

Si colonne C a autre chose que des dates donne erreur!
Y a-t-il moyen dit mettre un test sinon je vide tout ce qui n'est pas date

temjeh
 
Dernière édition:

Jocelyn

XLDnaute Barbatruc
Re : Test sur colonne avec condition date

re,

Hum hum tu peux tester cette formule

Code:
=SOMMEPROD((MOIS(SI(MOD(LIGNE(C4:C35);6)=4;C4:C35))<=G1*3)*(MOIS(SI(MOD(LIGNE(C4:C35);6)=4;C4:C35))>(G1-1)*3)*(I7:I38="Poste:")*J7:J38)
Attention c'est une formule sommeprod mais a valider matriciellement, la formule avec la plage nommée du 2° classeur peut être modifiée de la même façon elle sera elle aussi a valider matriciellement

autrement il faudra virer toutes les autres valeur de la colonne C

Regardes et dis

EDIT Je te joint le fichier avec les 2 formules modifiées
 

Fichiers joints

Dernière édition:

job75

XLDnaute Barbatruc
Re : Test sur colonne avec condition date

Bonjour Temjeh,

Avec cette formule matricielle on peut avoir des textes (en fait n'importe quoi) en colonnes C ou J :

Code:
=SOMME(SI(ESTNUM(MOIS(C4:C35)*J7:J38);(I7:I38="Poste:")*(MOIS(C4:C35)<=G1*3)*(MOIS(C4:C35)>(G1-1)*3)*J7:J38))
Edit : bien le bonjour Jocelyn, désolé j'ai oublié de te saluer :)

Note que s'il faut valider matriciellement SOMMEPROD il est plus simple d'utiliser SOMME tout court...

A+
 
Dernière édition:

Temjeh

XLDnaute Accro
Re : Test sur colonne avec condition date

Parfait merci beaucoup

J,avais opter pour cette solution en gardans juste les dates (compliqué, j'en ai beaucoup)
=SOMMEPROD((I7:I38="Poste:")*(MOIS(C4:C35)<=G1*3)* (MOIS(C4:C35)>(G1-1)*3)*J7:J38)

Mais celle-ci de job75donne un très bon résultat
=SOMME(SI(ESTNUM(MOIS(C4:C35)*J7:J38);(I7:I38="Poste:")*(MOIS(C4:C35)<=G1*3)*(MOIS(C4:C35)>(G1-1)*3)*J7:J38))

Sauf que si je met 2 comme trimestre j'ai 0$
Problème régler
 

Temjeh

XLDnaute Accro
Re : Test sur colonne avec condition date

Désolé
ERREUR d'adaptation à ma feuille maître
job merci beaucoup elle fonctionne à merveille

Et merci encore Jocelyn
temjeh
 
Dernière édition:

job75

XLDnaute Barbatruc
Re : Test sur colonne avec condition date

Pardon j'annule, je n'avais pas vu le post précédent.
 
Dernière édition:
Haut Bas