TCD ou SOMMEPROD, mon coeur balance

antiphot

XLDnaute Occasionnel
Bonjour à toutes et à tous


Bien que n'étant pas tres porté sur les formules, j'essaie de constituer un fichier avec une base de données sur laquelle je désire effectuer des extractions, calculs etc... sans passer par du vba. Cependant par la nature même de mes tableaux (voir exemple ci-joint) je ne sais pas trop comment mettre ces données en forme dans un TCD. J'ai également essayé la formule SOMMEPROD, mais je n'arrive pas à saisir tous les critères.

C'est pourquoi j'ai mis dans le fichier joint un exemple concret du calcul que je désire effectuer et je suis preneur de tous les conseils concernant la mise en forme de mes tableaux qui est j'imagine perfectible.

Je remercie par avance aux personnes qui sauront m'éclairer de leur savoir.

Amicalement
Philippe
 

Fichiers joints

poulie

XLDnaute Impliqué
Re : TCD ou SOMMEPROD, mon coeur balance

Bonjour antiphot, bonjour à tous,

Une première proposition pour la liste des codes, si j'ai bien saisi. Je n'ai pas bien compris pour la seconde question. Eventuellement saisis les résultats attendus?.

Bonne réception
 

Fichiers joints

antiphot

XLDnaute Occasionnel
Re : TCD ou SOMMEPROD, mon coeur balance

Bonjour Poulie


Je te remercie pour le travail que tu as déjà effectué et il me reste à décortiquer ta formule pour en comprendre le cheminement.
En ce qui concerne ma deuxième question j'ai essayé de préciser ma demande avec le résultat attendu dans le résultat final.

merci encore pour ton aide

Philippe
 

Fichiers joints

JCGL

XLDnaute Barbatruc
Re : TCD ou SOMMEPROD, mon coeur balance

Bonjour à tous,
Salut Poulie,

Pour ta cellule E5 :

Code:
=SOMMEPROD((FormMil!$G$3:$S$3=B5)*(FormMil!$D$4:$D$15=E2)*FormMil!$G$4:$S$15*FormMil!$F$4:$F$15)
Pour toute la plage : en C3 et vers la droite et vers le bas :

Code:
=SOMMEPROD((FormMil!$G$3:$S$3=$B3)*(FormMil!$D$4:$D$15=C$2)*FormMil!$G$4:$S$15*FormMil!$F$4:$F$15)
A+ à tous
 
Dernière édition:

antiphot

XLDnaute Occasionnel
Re : TCD ou SOMMEPROD, mon coeur balance

Bonjour JCGL

Merci pour cette proposition cela correspond parfaitement à ma demande.

Philippe
 

poulie

XLDnaute Impliqué
Re : TCD ou SOMMEPROD, mon coeur balance

antiphot, bonsoir JCGL,

Une tentative d'explication pour la première formule. Il s'agit d'une formule matricielle à valider en appuyant simultanément sur Ctrl+Maj+Entrée.

Bonne soirée
 

Fichiers joints

Discussions similaires


Haut Bas